# Table of Contents

**Standard Reports** ................................................................. 3
  - Use Standard Reports ................................................................. 3
  - Define Report Criteria ................................................................. 3

**Abra Secure Query** ............................................................... 13
  - Before you begin .............................................................................. 14
  - Create a New Query ................................................................. 14
  - Edit a Query ............................................................................. 15
  - Filter a Query ........................................................................... 16
  - Copy a Query ........................................................................... 16
  - Rename a Query ........................................................................ 16
  - Delete a Query ........................................................................ 17
  - Select Fields ............................................................................ 17
  - Group Records ........................................................................ 18
  - Sort Records ............................................................................ 18
  - Set Record Filter ....................................................................... 19
  - Output Results ........................................................................ 23
  - View Data or Run a Query ............................................................. 25

**Employee Reports** .............................................................. 27
  - Benefit Reports ........................................................................ 27
  - Code Table Reports ................................................................. 29
  - Compensation Reports ............................................................. 31
  - EEO Reports ............................................................................ 33
  - Employment Equity Reports .................................................... 35
  - Employee and Organization Reports ........................................ 36
  - Leave Reports .......................................................................... 37
  - OHS Reports ........................................................................... 37
  - OSHA Reports .......................................................................... 38
  - Pay Equity Reports ................................................................... 39
  - Personal Information Reports .................................................. 40
  - Skill and Education Reports ..................................................... 41
  - Wellness Reports ........................................................................ 41
Time Off Reports ........................................................................................................................ 42
Code Table Reports ........................................................................................................................ 44

**Payroll Reports** .......................................................................................................................... 47
Employee Reports ........................................................................................................................ 49
General Ledger Reports .............................................................................................................. 49
Government Reports .................................................................................................................... 50
Periodic Processing Reports ........................................................................................................ 51
Setup Reports ............................................................................................................................... 51
Tax Reports ................................................................................................................................. 52
Transaction Reports .................................................................................................................... 53

**Training Reports** ........................................................................................................................ 55
Catalogs and Code Tables ........................................................................................................... 55
Class Administration Reports .................................................................................................... 56
Employee Training Reports ....................................................................................................... 57
Training Analysis Reports .......................................................................................................... 59

**Custom Reports - Using Crystal Reports** ............................................................................... 63
Overview ........................................................................................................................................ 63
Abra Data Access ........................................................................................................................ 63
Create a Custom Report .............................................................................................................. 65
Add a Table .................................................................................................................................. 67
Sorting, Grouping, and Totaling .................................................................................................. 68
Custom Attendance Reports ....................................................................................................... 70
Custom HR Reports .................................................................................................................... 71
Custom Training Reports ........................................................................................................... 78

**Index** ......................................................................................................................................... 79
Standard Reports

Use Standard Reports

Sage Abra SQL HRMS provides dozens of preformatted reports designed to meet virtually any reporting need. With the standard reports, you can:

- Preview reports on your monitor.
- Print reports to your printer.
- Export reports to a disk file for use by other software applications.

Note: You can also create your own original reports using Crystal Reports® for Sage. Refer to the Crystal Reports online Help for detailed instructions on how to use Crystal Reports.

Select Reports

Before you start working with the standard reports, you must first select a report. The first step in selecting a report is accessing the report group.

To Select a Report

1. From the Navigation Pane, select Reports > Employees, Time Off, Payroll, or Training > the report you want to work with. The Reports dialog box opens and lists the reports in the selected group.
2. Scroll through the list and highlight the report you want to run. Sage Abra SQL HRMS enables all buttons and tabs and displays the name of the report selected at the bottom of the dialog box.
3. Define the criteria for your report.
4. Print, preview, or export the report.

Define Report Criteria

When you select a report, Sage Abra SQL HRMS provides various criteria by which to generate the report. For example, if you want to sort the Employee Profile report by employee number rather than employee name, you can choose employee number as one of your sort criteria. The Reports dialog box lets you limit the data appearing on a report. If you do not limit the data, the report includes all the records. Make selections to indicate only those records meeting your specific criteria.

The information on the tabs of the Reports dialog box enable you to tailor the output of your report. Using sorting options and selection criteria, you can produce a variety of different reports to meet your specific needs. You can:

- Use standard selection criteria such as employer, organization levels, and exempt status.
- Enter your own criteria to select information to include in the report.
Define Report Criteria

- Select specific employees to include in the report.
- Select report-specific options including (among others) the effective date or date range, a grouping by organization level, a sort order by employee name or ID, or form alignment options.
- Save default report options for the next time you use the same report.

Note: After you generate a report by printing, previewing, or exporting it, Sage Abra SQL HRMS saves your selection criteria. The next time you select that report, the saved options appear in the fields. Change the selection criteria as necessary for your new report.

Report List Tab

The Report List tab enables you to select a report, set the number of copies to print and save the current report options as your defaults.

Select a Report

From the list of reports, find the report you want and highlight it (click once). Sage Abra SQL HRMS enables all buttons and tabs to start defining the report options.

Specify a Print Range

The Print Range enables you to print all the pages of the report or only a specific range of pages.

To print the whole report, click the All radio button. To print a specified page range, click the Page radio button and enter the first and last page numbers.

Save Report Options

The Save Defaults button lets you save report options that you regularly use. Then the next time you generate the report, the settings are already defined for you. This feature comes in handy when you frequently generate a particular report.

If you have entered new settings for a report and want to return to the last settings you saved, click Restore Defaults.

Standard Criteria Tab

The Standard Criteria tab lists the general selection criteria that apply to all reports in a report group. You use these selection criteria to determine which employees will be selected for inclusion in the report.

Select the Employer

Using the Employer field, you can choose to include in your report employees in the Enterprise, in an individual employer or in multiple employers.

Do one of the following:

- Select Enterprise to include all the employees in all the employers you have set up in Sage Abra.
- Select an individual employer to include only the employees in that employer.
- Select **Multiple** to include the employees in more than one employer. When you select **Multiple**, a two-list chooser opens for you to select employers.

For each employer you want to include in your report, double-click the employer name to move it to the **Selected** list. Click **OK**.

**Select Organization Levels**

After you select the Enterprise or one or more employers, select the specific organization levels on which to report. The names of the organization levels are the same as the titles defined when you set up the Enterprise (up to five levels).

The organization descriptions included in each list depend on two factors: the employer selection and how you set up your organization codes. For example, if you select **Enterprise** as your employer and all your employers are using Enterprise level organization codes, the lists contain the organization descriptions you set up for the Enterprise.

Alternately, if you select **Enterprise** as your employer and you set up organization codes for each employer at the employer level (that is, you set up different codes for each employer), the lists include every employer’s organization descriptions.

**Note:** If you see duplicate entries in the list, this means you set up different organization codes at the employer level, but the descriptions you set up for the codes are the same.

**Note:** If you change your employer selection, Sage Abra SQL HRMS clears all organization levels. You can then reselect your organization levels.

**Select Employees**

If you want to further limit your report results, you can select specific employees within the employers you selected. Using the buttons adjacent to **Employee**, specify which employees you want to select.

If you are using Training, you can also use the buttons to specify which courses or classes you want to include, depending on the type of training report you are running. For example, you can select classes for Class Administration reports and courses for most Training Analysis reports.

**Select One Employee**

Click the **Find** button to select one employee. The Employee Find dialog box opens so you can find and select the employee you want to include.

After you find the employee, Sage Abra SQL HRMS displays the selected employee’s name, employee number, and employer ID.
Define Report Criteria

**Note:** When you select one employee, Sage Abra SQL HRMS disables all other selection criteria. If you want to cancel your employee selection, click the **Update** button. This re-enables all selection criteria.

**Select Multiple Employees**

To select multiple employees, click the **Multiple** button. The Employee Selection page opens. Select the employees you want to include. If you have already selected a single employee, it automatically appears in the list of selected employees.

The **Available** list includes all employees in the employers selected and displays the employee’s name, number, and employer ID. Double-click to select an employee name and move it to the **Selected** list. Similarly, double-click an employee name in the **Selected** list to move it back to the **Available** list.

After selecting, click **OK** to return to the dialog box.

**Points to Consider When Selecting Specific Employees**

When you are defining your report selection criteria by selecting employers, organization codes, and specific employees, note that if you have already selected the employer or organization codes and then attempt to select a specific employee, you might receive a message that there are no employees matching your selection. This is because the employee you tried to select does not belong to the employer or the selected organization codes.

If you want to run the report for a specific employee, select blank for all your organization codes and then select the employee.

**Select Employees by Employee Status**

Each employee you enter in Sage Abra SQL HRMS has an employee status.

When you generate a report, you can include employees who have an employee status of Active, Leave of Absence, or Terminated. Use the check boxes to select one or more employee statuses.

When you run reports in Training, you can select employees who are Active, Terminated, on Leave of Absence (LOA) and Non-employees.

**Select Employees by Exempt Status**

When you run reports in Abra HR or Time Off, use the **Exempt** field to generate a report to include employees by their overtime exempt status. Select **Exempt** or **Nonexempt** from the list. If you leave the field blank, the report includes both exempt and nonexempt employees.
Define Report Criteria

Select Employees by a Changed Since Date
When you run reports in Abra HR or Time Off, you can choose to include in your report only those employees whose information has changed since a specific date. Enter the date in the Changed Since field.

Select Classes by Status
When you run reports in Training, you can select classes that are Open, In Progress, Completed, and Canceled.

Define Custom Criteria
To generate reports using criteria other than what is already provided in Sage Abra SQL HRMS's standard selection criteria, use the Custom Criteria function.

Specific Criteria Tab
The Specific Criteria tab presents options you can set for the report you selected. Sage Abra SQL HRMS generates the report using these settings and the selection criteria you defined on the Standard Criteria tab.

The options on this tab vary from report to report within the report category you selected. Some examples of options specific to a report are date range, sort order, and effective date.

Define Custom Criteria
The Custom Criteria function enables you to generate reports using criteria other than what is already provided in Sage Abra SQL HRMS standard selection criteria.

Note: When you use any custom criteria, Abra HR disables all other selection criteria. To clear your custom criteria selection, select the blank option from the list.

Use the Custom Criteria Table
In Sage Abra SQL HRMS, you can create expressions that define specific criteria for selecting employees. Sage Abra SQL HRMS stores these expressions in the Criteria Code table. When you set up options for your reports, you can choose a criteria code from (or add a new one to) the Criteria code table. Sage Abra then generates the report according to the expression set up for the criteria code you selected.

Tip: If the expression you want to create is one you will be using more than once, it is a good idea to add it to your Criteria code table. Then, it will be available for you to select any time you need it. Follow the steps below to add a new criteria code.

Select Custom Criteria Table from the Custom Criteria list. The Criteria Table dialog box opens and lists the criteria codes you defined in your Criteria Code table.
Define Report Criteria

Note: If you did not define any criteria codes, only the selection Add New Code appears in the list.

Criteria Code Actions

To Select an Existing Criteria Code
1. From the Criteria Table dialog box, highlight the code.
2. Click OK. The expression appears in the Custom Criteria field.

To Add a New Criteria Code
1. From the Criteria Table dialog box, click Add New Code.
2. Click OK to open the Criteria Table dialog box.
3. Enter a description for your criteria.
4. Click OK. The Visual FoxPro Expression Builder opens.
5. Create an expression. The preceding figure shows an expression to generate a report for only seasonal workers. We selected the field P_SEASONAL from the Employee Personnel database and set it equal to (Y)es.
6. When you complete the expression, click OK. The expression displays in the Custom Criteria field. Abra HR uses this expression to generate a report that includes only seasonal employees.

Use the Custom Criteria Builder

You can use the Sage Abra Criteria Builder to build expressions for your selection criteria and save them to your criteria code table.

Note: The Criteria Builder enables you to create an expression with fields only from the Employee Personnel (HRPERSNL) database. If you need to build an expression with fields from a database other than HRPERSNL, you must use the Expression Builder.

The following steps build an expression you would use to produce a report that includes Production Managers who started their jobs on or after January 1, 2002. Building this expression requires you to define two selection criteria: employees whose Job Title is Production Managers and of those Production Managers, those who started their job on or after 01/01/02.

To Create an Expression with the Criteria Builder
1. Select the Criteria Builder option from the Custom Criteria list. The Criteria Builder dialog box opens.
2. From the Field list, select Job Title.
3. From the Relationship list, select Equal To.
4. In the Value field, type Production Managers.
5. Since we need to define another criteria, click the **And** button. The first part of the expression appears in the dialog box and we’re ready to enter the second criteria.

6. From the **Field** list, select **Job Start Date**.

7. From the **Relationship** list, select **Greater Than or Equal To**.

8. In the **Value** field, type 01/01/02.

9. Click the **Done** button. The dialog box now shows the complete expression.

10. To save the Expression to your criteria code table, click the **Save To Criteria Table** button. The Criteria Table dialog box opens.

11. Type a description for your new expression.

12. Click **OK**.

   **Note:** If you want to delete all the criteria you defined and start over, click **Reset**. If you want to delete one criteria at a time (from the last to the first), click **Undo**.

**Use the Expression Builder**

You can access the Visual FoxPro Expression Builder any time you need to create an expression for your custom criteria. Select **Visual FoxPro Expression Builder** from the **Custom Criteria** field. The Expression Builder opens for you to start building your expression. When you have completed it, click **OK**. Your expression is available from the **Custom Criteria** field list when you generate reports within the selected report category. Refer to Expressions and Functions, for detailed instructions on using the Expression Builder.

**Tip:** If you only need to use fields from the Employee Personnel database (HRPERSNL) in your expression, consider using the Criteria Builder rather than the Expression Builder. The Criteria Builder is somewhat easier to use than the Expression Builder. However, if you need to build an expression with fields from any database other than HRPERSNL, you must use the Expression Builder.

**Print, Preview, or Export a Report**

After you determine your standard and specific selection criteria, generate your report by choosing whether to send it to your printer, preview it on the monitor, or export it to a file on the server.

**Preview a Report**

To preview a report on the monitor, click **Preview**. The system opens a preview window and presents the report.

You can identify each report by its title. The title is at the top of each page of the report. The date and time the report was generated appear at the bottom of each page, along with a sequential page number. Report totals and other control numbers also appear at the end of most reports.

Reports are formatted for standard 8 1/2-by-11-inch paper with a half-inch margin on all sides.
Define Report Criteria

**Page Preview Toolbar**
When you preview a report, the page preview toolbar enables you to enlarge your view, scroll through the report, and print the report. You can see the button’s description as you position your cursor over the button.

The following table describes the buttons on the page preview toolbar.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>First Page</td>
<td>The First Page button displays the first page of the report. This button is disabled if you are previewing the first page of the report.</td>
</tr>
<tr>
<td>Previous Page</td>
<td>The Previous Page button displays the previous page of the report. This button is disabled if you are previewing the first page of the report.</td>
</tr>
<tr>
<td>Go To Page</td>
<td>The Go To Page button lets you select a specific report page to display.</td>
</tr>
<tr>
<td>Next Page</td>
<td>The Next Page button displays the next page of the report. This button is disabled if you are previewing the last page of the report.</td>
</tr>
<tr>
<td>Last Page</td>
<td>The Last Page button displays the last page of the report. This button is disabled if you are previewing the last page of the report.</td>
</tr>
<tr>
<td>Zoom</td>
<td>The Zoom control lets you choose six different magnifications. You can also click your cursor anywhere in the preview window to zoom in or out on a particular area of the report. When you zoom, your cursor changes to a magnifying glass.</td>
</tr>
<tr>
<td>Close Preview</td>
<td>The Close Preview button closes the preview window and returns to the Reports dialog box. You can also click the Close Preview button in the report title bar to close the preview window.</td>
</tr>
<tr>
<td>Print Report</td>
<td>Click the Print Report button to print the report.</td>
</tr>
</tbody>
</table>

**Print a Report**
From the reports dialog box, click Print to open the Print Options dialog box. Select the appropriate options such as page range, number of copies, and name of printer. Note that if you have a PDF driver installed, you can create a PDF version of the report and then send it as an email attachment.
Export a Report to a File

Sage Abra SQL HRMS enables you to export or save your report to a file so you can use it in a variety of different applications, such as Lotus 1-2-3 or Microsoft Excel.

1. Click Export to export a report to a file. The File Export Options dialog box opens. If working with Veterans Employment report, when you click Export, the File Type defaults to Electronic Submission format.

2. Select the file format to use from the File Type list. The extension in the File Name field automatically fills in according to the File Type you select.

3. Enter up to eight characters for the file name in the File Name field. Then, click Export.

4. Click OK. Sage Abra SQL HRMS exports the file to the ..\Sage\SageAbraSQLHRMSServer\Data\Export directory on the server.

   **Note:** If you are using Windows 2008, Windows 7, or Windows Vista, you must reset the View properties on the C drive so that you can see the \ProgramData folder to where the reports are exported. Open Windows Explorer and do the following:

   a. Go to Organize > Folder and Search Options.

   b. Click the View tab.

   c. Select the Show hidden files and folders button and click OK.
Define Report Criteria
Abra Secure Query is a desktop query and reporting tool that enables you to quickly and easily generate or modify requests for specific information. For example, sometimes you just need answers in a hurry to prepare for a meeting or to help make projections. Abra Secure Query makes it easy to get the information you need.

Using Abra Secure Query you can select which fields to output, sort results in ascending or descending order, build record filters, and group and summarize fields. When finished you can choose to output the query as a report, spreadsheet, text file, or database table. You can also create and save a virtually unlimited number of queries and reuse these queries any time you need the information.

Use Ad Hoc Reporting Security to restrict the database files and fields available to a security group using Abra Secure Query. Ad Hoc Reporting Security lets you assign an access level to each field contained in your Abra databases.

Setting a group’s Ad Hoc Reporting Security Level works in conjunction with setting Ad Hoc Reporting Security. When you set up group security, (From the Navigation Pane, select Setup > System > Group Security link ), you establish an access level that determines which fields in the Abra system databases are able to be accessed by the security group’s users whenever they use Abra Secure Query.

Refer to Set Up Sample Queries to guide you through the process of defining your queries. In addition, sample queries are provided in sample data for each installed product. If you are working with live data, you might want to see how a query works before you create it. Switch from live data to sample data to practice with the sample queries before creating your own custom queries.

**Note:** Queries created in sample data cannot be copied or imported from sample data to live data.

From the Query Main page you can:

- Select Fields
- Group Records
- Sort Records
- Set Record Filter
- Output Results
- View Data and Run Queries

Abra Secure Query makes it easy to create custom queries to help you analyze and interpret important information.
Before you begin

Before you begin working with queries, we recommend you review Set Up Sample Queries to guide you through the process of creating queries. In addition, sample queries are provided in sample data for each installed product. If you are working with live data, you might want to see how a query works before you create it. Switch from live data to sample data to practice with the sample queries before creating your own custom queries.

Before you begin, review some basic information that will help you create effective and efficient queries:

- Only the author of a query or the Abra System Administrator can change the access type, edit, or delete a query.
- View the data retrieved by your query at any time, by clicking either the View Data button or the Run Query button at the bottom of the page.

Create a New Query

1. From the Navigation Pane, select Reports > Employees or Training subgroup > Abra Secure Query.
2. Click New. The Enter a Title for this New Query dialog box opens.
3. In the New Title field, enter a title for the query. This field is required because the query name appears at the top of pages and prints on most reports.
4. Select an Access Type of either Private (personal use only) or Public (for all users who have access to Abra Secure Query). Queries with a public access type can be viewed and copied for modification by all users who have access to Abra Secure Query.
5. Click OK. The Select Data To Use in Query dialog box opens.
6. On the Choose Employee Information tab, select the type of information to include in the query from the Master Table. To define the fields in your query, you must know which Abra pages contain the fields you need. The pages you will always use contain fields from the Master Table. The Employee Master Table contains all the primary data for an employee in Abra HR, Time Off, or Training.
7. If you want all the fields from the Master Table available to choose from, click the Advanced button. The Advanced Field Options dialog box opens.
8. Select Make all Employee Master Table fields available for this query and click OK. The Select Data To Use in Query dialog box opens.
9. To select additional optional information from a second table, click the Choose Additional Information tab.
10. On the Choose Additional Information tab, select the appropriate type of additional information you want to include in the query.
11. Click OK. The Select Fields to Show in Query dialog box opens. The Fields to pick from list depends on the tables you have selected from the Select Data To Use in Query dialog box. The Fields to include in query list shows those fields you selected.

12. From the Fields to pick from list, double-click the fields or press the Shift and Ctrl keys to select the fields you want to include in the query. The selected fields appear in the right list in the order in which you selected them. This is the order in which Abra displays the fields in your query. To remove a field from the Fields to include in query list, highlight it and click Remove or double-click it.

13. To change the order of the fields, move your cursor over the button to the left of the field until you see a two-headed arrow. Press your left mouse button and drag the field to the new position. Release the mouse button. The field moves to the new position and the other fields automatically reorder to accommodate the moved field.

14. Click OK after you have selected the appropriate fields. The Query Main page opens.

15. From the Query Main page you will:
   - Select Fields
   - Group Records
   - Sort Records
   - Set Record Filter
   - Output Results
   - View Data and Run Queries

---

**Edit a Query**

1. From the Navigation Pane, select Reports > Employees or Training subgroup > Abra Secure Query.

1. From the list of queries, select the one to edit and click Open.

2. The Query Main page opens.

3. From the Query Main page you will:
   - Select Fields
   - Group Records
   - Sort Records
   - Set Record Filter
   - Output Results
   - View Data and Run Queries
Filter a Query

1. From the Navigation Pane, select Reports > Employees or Training subgroup > Abra Secure Query.
2. The first time you click the Filter button in a query, the Set Record Filter dialog box opens. After you add your first condition to a record filter, the system opens the Conditions List page. From the Conditions List page you will:
   - Add a New Condition to a Record Filter
   - Edit a Condition
   - Switch a Connector
   - Move a Condition
   - Bracket Two or More Conditions
   - Delete a Condition

Copy a Query

1. From the Navigation Pane, select Reports > Employees or Training subgroup > Abra Secure Query.
2. From the list of queries, select the one you want to copy and click Copy. The Enter a Title for this Copied Query dialog box opens.
3. In the To New Title field, enter a new title for the query. This field is required because the query name appears at the top of pages and prints on most reports.
4. Select an Access Type of either Private (personal use only) or Public (for all users who have access to Abra Secure Query).
5. Click OK.

Rename a Query

1. From the Navigation Pane, select Reports > Employees or Training subgroup > Abra Secure Query.
2. From the list of queries, select the one you want to rename and click Rename. The Enter a New Title for this Query dialog box opens.
3. In the New Title field, enter a new title for the query. This field is required because the query name appears at the top of pages and prints on most reports.
4. Select an Access Type of either Private (personal use only) or Public (for all users who have access to Abra Secure Query).
5. Click OK.
Delete a Query

1. From the Navigation Pane, select Reports > Employees or Training subgroup > Abra Secure Query.
2. From the list of queries, select the one you want to delete and click Delete. The system asks you to confirm the deletion.
3. Click Yes to confirm the deletion, or click No to cancel the deletion.

Select Fields

The Select Fields tab enables you to limit the results that are returned in your query to only those records that you are interested in. The Select Fields tab lists previously saved fields for the selected query.

1. From the Select Fields tab, click the Select Fields button. The Select Fields to Show in Query dialog box opens.
2. The Fields to pick from list depends upon the tables you have selected from the Select Data To Use in Query dialog box. The Fields to include in query list shows those fields you selected.
3. From the Fields to pick from list box, double-click or use the SHIFT and CTRL keys to highlight the fields you want to include in the query, and then click the Select button to move them to the Fields to include in query list box. They appear in the order in which you selected them. This is the order in which Abra displays the fields in your query. If you want to remove one or more fields from the Fields to include in query list, highlight them and click Remove or double-click them, to move them back to the other list.
4. To change the order of the fields, move your cursor over the button to the left of the field until you see a two-headed arrow. Press your left mouse button and drag the field to the desired position. Release the mouse button. The field moves to the new position and the other fields automatically reorder to accommodate the moved field.
5. Click OK after you have selected the appropriate fields. The Query Main page opens.

Additional Data

1. From the Select Fields tab, click Additional Data. The Select Data To Use in Query dialog box opens.
2. From the Choose Employee Information tab, select the type of information you want to include in the query from the Master Table. To define the fields in your query, you must know which Abra pages contain the fields you need. The pages you will always use contain fields from the Master Table. The Employee Master Table contains all the primary data for an employee in Abra HR, Time Off, and Training.
3. If you want all the fields from the Master Table available to choose from, click Advanced. The Advanced Field Options dialog box opens.
4. Select Make all Employee Master Table fields available for this query and click OK. The Select Data To Use in Query dialog box opens.
5. If you want to select additional optional information from a second table click the **Choose Additional Information** tab.

6. From the **Choose Additional Information** tab, select the appropriate type of additional information you want to include in the query.

   **Note:** You cannot remove a table from the query after you have selected it.

7. Click **OK**.

### Group Records

Use the **Group Records** tab to specify how fields will be grouped and summarized in your query.

Grouped data is data that is divided into meaningful groups. For example, a group might consist of all those employees who have the same job title or are in the same department.

1. From the **Group Records** tab, select the fields you want the records grouped by from the drop-down lists. The values in the drop-down lists depend upon the fields you have selected from the **Select Fields To Use in Query** dialog box.

2. Select **Count the number of records in the group** to add a count of the values within each group to the query.

3. Select **Detail records in the group** to display all the data. If you want to display a summary of the totals for each group, clear the selection. Summary information is most useful when you do not need detailed information and you only want to examine totals.

4. By default, numeric fields are displayed in the **Summarize the records for this numeric** field. From the list of fields, select the one you want to summarize and click once to highlight it.

5. Select the appropriate radio button or the type of summary information you want for your query.

   Abra Secure Query includes a number of summarizing options:

   a. **None**

   b. **Sum the records in this field** - adds the values within a group, to provide a total.

   c. **Average the records in this field** - finds the average of all values within a group.

   d. **Find the smallest value in this field** - finds the minimum value within a group.

   e. **Find the largest value in this field** - finds the maximum value within a group.

### Sort Records

The **Sort Records** tab lists previously saved sorts for the selected query. If you have not selected a sort option for your query, **Sorted by current record order** displays in the list. In this case, the data is displayed in the same order as it appears in your tables.

Sorting means placing data in some kind of order to help you find and evaluate it. When you sort, you define the field you want the sort to be based on and the sort direction.
**Set Record Filter**

**Sort Direction** refers to the order in which the values are displayed, once sorted.

- Ascending order means smallest to largest (1 to 9, A to Z).
- Descending order means largest to smallest (9 to 1, Z to A).

The fields you select for sorting automatically defaults to ascending order. (DESC) next to the field name indicates that the values in the field are sorted in descending order.

1. From the **Sort Records** tab, click the **Select Order** button. The Select Sorting Order dialog box opens.
2. The **Fields to pick from** list shows all the fields you selected for this query from the Select Fields to Show in Query dialog box.
3. The **Fields to sort records by** list shows those fields you select to sort on and the corresponding sort order.
4. From the **Fields to pick from** list box, double-click the fields or use the **SHIFT** and **CTRL** keys to select the fields you want to include in the query. The selected fields appear in the right list box in the order in which you selected them. This is the order in which Abra sorts the fields in your query. To remove a field from the **Fields to include in query** list, highlight it and click **Remove** or double-click it.
5. To change the order of the fields, move your cursor over the button to the left of the field until you see a two-headed arrow. Press your left mouse button and drag the field to the desired position. Release the mouse button. The field moves to the new position and the other fields automatically reorder to accommodate the moved field.
6. In single field sorting, all the records used in the query are sorted based on the values in a single field. Sorting a query by employee last name is an example of single field sort.
7. In multiple field sorts, Abra Secure Query first sorts the records based on the values in the first field, putting them in ascending or descending order as specified. When two or more records have the same field value in the first sort field, the system then sorts those records based on the value in the second sort field.
8. Click the **Sort Asc/Desc** button to change the sort order.
9. Click **OK**.

**Set Record Filter**

The **Set Record Filter** tab enables you to further define the records you want included in a query. In some cases, you might want to specify a particular value to further limit your results. For example, you might want to find only active employees.

Other times, you might want to create a query that enables you to specify different value each time. The record filter acts as placeholder for a value that is supplied when the query runs. For example, you might want to find employees hired during a certain date range. You could run the same query for each request, except that the original hire date range would be different each time.
The **Set Record Filter** tab lists previously saved conditions for the selected query in the order in which you added them. You can specify up to a maximum of 10 conditions. If the record filter contains conditions with set values, the conditions display with their assigned values. If the record filter contains conditions that can have different values at different times, the condition appears with {To be entered later}. **Set Record Filter** fields do not have to be placed in a query in order to be used as a condition in a record filter.

Select the **Hide Duplicate Output Records** check box if you do not want the query to display records that are duplicated.

**Add a New Condition to a Record Filter**

1. From the **Set Record Filter** tab, select **Hide Duplicate Output Records** to prevent the query from returning duplicate records from the database.

2. Click **Set Record Filter**.

3. The first time the Set Record Filter is used in a query, the Set Record Filter dialog box opens. Proceed to step 4. After you add your first condition to a record filter, the system opens the Conditions List page.

4. Click **Add**. The Select a Connector dialog box opens.

5. To require both this condition and the prior condition to be true, click **And**. Using **AND** enables you to specify that the values in a record filter must meet two (or more) conditions for the data to be included in the query. This option narrows the scope of the search and usually returns less data.

6. To require either this condition or the prior condition to be true, click **Or**. Using **OR** enables you to specify several alternative values in a record filter. This option expands the scope of the search and can return more data.

7. In the Set Record Filter dialog box, on the Pick a Field tab, select the field that contains the data you want to filter or specify.

8. Click **Next** to move to the **Pick an Operator** tab or the **Pick True or False** tab. The choices on the **Pick an Operator** tab or the **Pick True or False** tab depend on the type of field you select from the **Pick a Field** tab. Select the type of operator that describes the operation or action you want. If you select a True or False condition, the **Enter a Value** tab is disabled. Proceed to step 9.

9. Click **Next** to move to the **Enter a Value** tab if the system does not automatically move you to that tab.

10. The choices on the **Enter a Value** tab depend on the type of field you select from the **Pick a Field** tab and the type of operator you select from the **Pick an Operator** tab. From the **Enter a Value** tab:

    - Enter or select the appropriate value.

    - Click **Ask later** to create a record filter that prompts you for the values when the query is run.

    - Click **Compare to Field** to compare data from the field you selected on the **Pick a Field** tab with the content of another data field.

11. Click **OK**. The Conditions List page opens.
12. Click Cancel to discard your changes. A message asks if you want to exit without saving changes. 
   Click Yes if you are certain you do not want to save the changes.

13. When you are finished setting up the record filter, click Done. If the Enter a Value tab opens, click 
   Cancel.

**Edit a Condition**

1. From the Set Record Filter tab, click the Set Record Filter button. The Conditions List page opens 
   and lists previously saved conditions.
2. From the list, select the condition you want to edit.
3. Click Edit. The Set Record Filter dialog box opens.
4. From the Pick an Operator tab, select the type of operator that describes the operation or action you 
   want to take place.
5. Click Next to move to the Enter a Value tab, if the system does not automatically move you to that 
   tab.
6. The choices on the Enter a Value tab, depend upon the type of field you select from the Pick a Field 
   tab and the type of operator you select from the Pick an Operator tab. From the Enter a Value tab:
7. Enter or select the appropriate value.
8. Click the Ask later button to enable you to create a record filter that prompts you for the values 
   when the query is run.
9. Click the Compare to Field button to compare data from the field you selected on the Pick a Field 
   tab with the content of another data field.
10. Click OK. The Conditions List page opens.
11. Click Cancel to discard your changes. A message asks if you want to exit without saving changes. 
    Click Yes if you are certain you do not want to save the changes.
12. When you are finished setting up the record filter, click Done. If the Enter a Value tab opens, click 
    Cancel.

**Switch a Connector**

If a Record Filter includes more than one condition, the conditions are linked with either an AND (to 
   narrow the search) or an OR (to broaden it). If you want the values in a record filter to meet several 
   conditions, specify an AND connector. If you want to specify several alternative values, specify an OR 
   connector. Use the Switch button to change the connector that links two conditions.

1. From the Set Record Filter tab, click the Set Record Filter button. The Conditions List page opens 
   and lists previously saved conditions.
2. From the list of conditions, select the one you want to switch and click once to highlight the 
   condition.
3. Click Switch.
4. Click Cancel to discard your changes. A message asks if you want to exit without saving changes. 
   Click Yes to not save the changes.
5. When you are finished setting up the record filter, click **Done**. If the **Enter a Value** tab opens, click **Cancel**.

**Move a Condition**

1. From the **Set Record Filter** tab, click the **Set Record Filter** button. The Conditions List page opens and lists previously saved conditions in the order in which you added them. This is the order in which Abra evaluates the conditions in the record filter.
2. From the list of conditions, select the one you want to move and click once to highlight the condition.
3. Click **Move**. A check mark indicates the condition you selected.
4. Go to the location you want for the marked condition and double click.
5. The condition moves to the new position and the other conditions automatically reorder to accommodate the change.
6. Click **Cancel** to discard your changes. A message asks if you want to exit without saving changes. Click **Yes** if you do not want to save the changes.
7. When you are finished setting up the record filter, click **Done**. If the **Enter a Value** tab opens, click **Cancel**.

**Bracket Two or More Conditions**

Brackets enable you to add parentheses around two or more conditions to force those conditions to be evaluated together. For example, you might want to find employees hired during a certain date range with an employee status of either A (active) or L (leave of absence).

1. From the **Set Record Filter** tab, click the **Set Record Filter** button. The Conditions List page opens and lists previously saved conditions.
2. From the list of conditions, select the first one you want to include or if the condition already contains brackets, remove from the brackets. Click once to highlight the condition.
3. Click **Bracket**. The Insert or Remove Parentheses dialog box opens.
4. Click **Insert** to add parentheses. A check mark indicates the condition you selected.
5. Select the condition where you want to place the matching ending parentheses and double click.

   OR

6. Click **Remove** to remove existing parentheses. A check mark indicates the condition you select.
7. Select the condition that contains the matching ending parentheses and double click.
8. Click **Cancel** to discard your changes. A message asks if you want to exit without saving changes. Click **Yes** if you do not want to save the changes.
9. When you are finished setting up the record filter, click **Done**. If the **Enter a Value** tab opens, click **Cancel**.

**Delete a Condition**

1. From the **Set Record Filter** tab, click the **Set Record Filter** button. The Conditions List page opens and lists previously saved conditions.
2. From the list of conditions, select the one you want to delete and click Delete.
3. Click Cancel to discard your changes. A message asks if you want to exit without saving changes. Click Yes if you do not want to save the changes.
4. When you are finished setting up the record filter, click Done. If the Enter a Value tab opens, click Cancel.

Output Results

The Output Results tab enables you to tailor the output of your query. For each query you can:

- Generate a report
- Export the query to a file as an ASCII text file, for use in Microsoft Office applications, or as a data table.

Generate a Report

Select Report as your output when you want to view or print copies of your query in a report format. Reports are formatted for standard 8 1/2-by-11-inch paper with a half-inch margin on all sides. Portrait orients the print vertically and displays a maximum of 6 columns. Landscape orients the print horizontally and displays a maximum of 8 columns.

You can identify each report by the query title. The query title is at the top of each page of the report.

1. From the Output Results tab, select Report (Portrait Layout) or Report (Landscape Layout).
2. Click Run Query. The Report Setup dialog box opens.
3. Select the Output Direction.
4. To preview the report, select Preview.
5. To print the report, select Print. If you select to print the report, the Print Options dialog box opens. Select the appropriate options such as page range, number of copies, and name of printer. Note that if you have a PDF driver installed, you can create a PDF version of the report and then send it as an email attachment.
6. Click Start Report.

Page Preview Toolbar

When you are previewing a report, the page preview toolbar enables you to enlarge your view, scroll the pages, and print the report. You can see the button’s description as you position your cursor over the button.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="First Page" /></td>
<td>The First Page button displays the first page of the report. This button is</td>
</tr>
</tbody>
</table>
### Output Results

<table>
<thead>
<tr>
<th><strong>Button</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>disabled if you are previewing the first page of the report.</td>
</tr>
<tr>
<td></td>
<td>The <strong>Previous Page</strong> button displays the previous page of the report. This button is disabled if you are previewing the first page of the report.</td>
</tr>
<tr>
<td></td>
<td>The <strong>Go To Page</strong> button lets you select a specific report page to display.</td>
</tr>
<tr>
<td></td>
<td>The <strong>Next Page</strong> button displays the next page of the report. This button is disabled if you are previewing the last page of the report.</td>
</tr>
<tr>
<td></td>
<td>The <strong>Last Page</strong> button displays the last page of the report. This button is disabled if you are previewing the last page of the report.</td>
</tr>
<tr>
<td></td>
<td>The <strong>Zoom</strong> control lets you choose six different magnifications. You can also click your cursor anywhere in the preview window to zoom in or out on a particular area of the report. When you zoom, your cursor changes to a magnifying glass.</td>
</tr>
<tr>
<td></td>
<td>The <strong>Close Preview</strong> button closes the preview window and returns to the reports dialog box. You can also click X in the report title bar to close the preview window.</td>
</tr>
<tr>
<td></td>
<td>Click the <strong>Print Report</strong> button to print the report.</td>
</tr>
</tbody>
</table>

### Export a Query to a File

Sage Abra SQL HRMS enables you to export or save your query to a file so you can use it in a variety of different applications, such as Microsoft Excel.

1. From the **Output Results** tab, select the file format you want to use. The extension in the **Filename** field automatically fills in according to the **File Type** you select.
2. You can change the file name in the **Filename** field, for example, you may want to add a date to the file name. Enter up to 40 characters for the file name. The filename must contain only alpha and numeric characters, such as alphabetic characters a-z, A-Z, and numeric characters 0-9. Do not use any special characters, such as #, -, @, or punctuation marks.
3. Click **Run Query**. When the process is complete, a message displays the total number of records exported to your file, the location of the file, and asks if you want to view file. Sage Abra SQL HRMS exports the file to the \EXPORT directory in your Sage Abra SQL HRMS directory.
4. Click **Yes** to view the file.
View Data or Run a Query

You can view the data retrieved by your query at any time, by clicking either the View Data button or the Run Query button at the bottom of the page.

To View Data
To view the data on the monitor, click View Data. The system opens a preview window and presents the query. The data is displayed in the same order as it appears in your tables, with no grouping or sorting.

To Run a Query
1. Click Run Query.
2. If you have selected Report as the Output, the Report Setup dialog box opens.
3. Select the Output Direction.
4. To preview the report, select Preview.
5. To print the report, select Print.
6. When you send a report, it will be generated as a PDF file and require the recipient of the e-mail to have Adobe Reader. The standard Outlook dialogue for sending an e-mail will appear with the subject as Sage Abra Report and the report as an attachment.
7. Click Start Report.
8. Click Yes to view the file. If you do not have Adobe Reader installed, directions will be provided to where you can download it from the web and install it. If Outlook is not installed, the file will be placed in the export directory.

    If you have selected to output the results to a file, when the process is complete, a message displays the total number of records exported to your file, the location of the file, and asks if you want to view file now. Sage Abra SQL HRMS exports the file to the \EXPORT directory in your Sage Abra SQL HRMS directory.
Sage Abra SQL HRMS is shipped with dozens of preformatted reports. Reports are grouped into the following categories:

- Benefit Reports
- Code Table Reports
- Compensation Reports
- EEO Reports
- Employment Equity Reports
- Employee and Organization Reports
- Leave Reports
- OSHA Reports
- OHS Reports
- Pay Equity Reports
- Personal Information Reports
- Skill and Education Reports
- Wellness Reports

There are two report groups:

- Attendance Reports
- Code Table Reports

**Benefit Reports**

All benefits reports have a selection option for COBRA recipients. Most benefits reports prompt for the effective date. In this way, benefits that have expired or have yet to begin are not included.

These are the Benefit reports:

<table>
<thead>
<tr>
<th>Report Name</th>
<th>Report Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Benefit Coverage by Employee</td>
<td>This detail report lists personal and salary information about each employee, his or her benefits, the effective and expiration dates, the total cost of the monthly premiums for the employee, and the employee’s dependents and the amount the employee pays for coverage.</td>
</tr>
<tr>
<td>Report Name</td>
<td>Report Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Benefit Enrollment by Plan</td>
<td>This report totals benefits by plan. For insurance plans, the report totals employee monthly premium, dependent monthly premium, employee monthly contribution, and monthly net cost. For savings plans, the report totals monthly projected employee contribution and monthly employer match. You can run the report to either include or exclude waived benefit plans, as well as to include or exclude history records. You must enter an effective date for the report. Otherwise, if the date is left blank, the report might not include all the appropriate enrollment information.</td>
</tr>
<tr>
<td>Benefit Letter</td>
<td>This report is a letter showing the employee which benefits are set up for the employee.</td>
</tr>
<tr>
<td>Benefit Premium Totals by Plan</td>
<td>This report provides a summary headcount of each benefit plan. The report lists the plan, number of enrollees, coverage amount, employee monthly premium, dependent monthly premium, employee monthly contribution, and monthly net cost. You can select whether to include insurance or savings plans in the report as well as include or exclude history records.</td>
</tr>
<tr>
<td>Census Report</td>
<td>This report provides information most insurance companies require when calculating the cost of providing insurance. You might want to send this report directly to the insurance company. The Dependents column on the report indicates the number of insured as specified on the Dependents and Beneficiaries page. An insured spouse counts as one dependent.</td>
</tr>
<tr>
<td>Certificate of Coverage</td>
<td>This report shows proof of previous health insurance coverage for the employee. If the Date of Certificate (entered on the Specific Criteria tab) is greater than the date the employee’s coverage ended, the certificate will print the employee’s name, the date the coverage began (item #10), and the date the coverage ended (item #11). Otherwise, if coverage has not ended (as of the Date of Certificate), the report will display an X in item #11.</td>
</tr>
<tr>
<td>COBRA Billing Statement</td>
<td>Abra HR can track different types of COBRA at different rates. Abra HR prompts you to select which COBRA codes (or all) you want to use to create a report. Knowing COBRA law and how to administer it is your responsibility. We provide you with the tools to help manage COBRA but assume no liability. COBRA laws change and are subject to interpretation. The penalty for not following COBRA law is severe. If you are not well versed in COBRA requirements, please seek professional counsel.</td>
</tr>
<tr>
<td>COBRA Mailing Labels</td>
<td>This report prepares mailing labels for COBRA recipients in three-column label format (30 labels per page). You can select the COBRA codes you want to have labels. If sheets of labels don’t move smoothly through your printer, try printing the labels on regular paper, then use your copier.</td>
</tr>
<tr>
<td>COBRA Notification</td>
<td>This report prints a standard COBRA notification letter. You can select employees terminated in the Specific Criteria tab and all dependents and beneficiaries of the selected employees will print on the report. Otherwise, the report will be blank.</td>
</tr>
<tr>
<td>Report Name</td>
<td>Report Description</td>
</tr>
<tr>
<td>---------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Letter</td>
<td>within a specific date range. You can also specify a markup factor.</td>
</tr>
<tr>
<td>COBRA Recipient Report</td>
<td>This report lists people receiving COBRA benefits and how long they have received these benefits. The report lists the recipient's name, division and department, termination reason, date of termination, number of months the individual has received COBRA, and the number of total dependents, including the insured.</td>
</tr>
<tr>
<td>Employee Benefit Changes</td>
<td>This report shows changes in employee benefits. You can select whether to include or exclude history records.</td>
</tr>
<tr>
<td>Insurance Coverage Detail</td>
<td>This report contains detailed information about each employee’s insurance benefit plans. It lists the dependents covered under each plan, shows when their coverage was in effect, and also shows the individual coverage and premium amounts for each dependent, when applicable. The report also contains insurance plan information that is currently not available on any other standard reports. You can run the report to either include or exclude waived benefit plans, as well as to include or exclude history records.</td>
</tr>
</tbody>
</table>

## Code Table Reports

Review all the defined codes in your code tables by printing your code table reports. Use these reports as a reference before or after updating your code tables for the enterprise or each employer.

Sage Abra SQL HRMS provides the following code table reports:

- Aboriginal Codes
- Attachment Codes
- Benefit Insurance Plans
- Benefit Rate Tables
- Benefit Savings Plans
- Benefit Type Codes
- Census Metro Area Codes
- Consent Types
- Dependent Relationship Codes
- Direct/Indirect Codes
- Disability Codes
- EE Category Codes
• EE Occupational Group Codes
• EEO Classification Codes
• EEO Job Group Codes
• EEO-4 Job Function Codes
• Employee Note Author Codes
• Employee Note Type Codes
• Employee Type Codes
• Ethnic ID Codes
• Event Codes
• FMLA Event Reason Codes
• Industrial Sector Codes
• Job Classification Codes
• Job Codes
• Job Family Codes
• Job Status Codes
• Language Codes
• NOC Occupation Group Codes
• OHS Body Part Codes
• OHS Injury Codes
• OHS Injury Location Codes
• OSHA Body Part Codes
• OSHA Injury Codes
• OSHA Injury Location Codes
• Organization Codes
• Pay Equity Job Group Codes
• Rating Codes
• Reason Codes
• Salary Grades
• Shift Differential Codes
• Skill Codes
• State/Province Codes
• Step Rate Codes
• Union Codes
• User-Defined Codes
• Visible Minority Codes

Sage Abra SQL HRMS also provides the following code table reports for Time Off:
• Absence Reason Codes
• FMLA Event Reason Codes

Compensation Reports

These reports track reviews, new hires and terminations, a variety of salary analyses and job code statistics.

Many compensation reports include the compa-ratio statistic. The compa-ratio is the employee’s percent-of-midpoint within a salary range. This is the formula for calculating compa-ratio:

\[
\text{Compa-ratio} = \frac{\text{Employee's salary}}{\text{Midpoint for Salary Grade}} \times 100
\]

Note: Compa-ratio calculations do not print unless you enable the Salary Grade Table Validation during employer setup.

<table>
<thead>
<tr>
<th>Report Name</th>
<th>Report Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ranked Salary List</td>
<td>This report ranks, in descending order, the annual salaries of all your employees. The report includes annual salaries, unit rate, employees, employee titles, and organization level. You can select to include all, exempt or nonexempt employees.</td>
</tr>
<tr>
<td>Reviews Due</td>
<td>This report provides a list of performance and salary reviews by month. You can include performance or salary reviews and sort by organization level or supervisor.</td>
</tr>
<tr>
<td></td>
<td>If you request open reviews, Sage Abra SQL HRMS includes reviews with a Next Review Date that is earlier than the one specified. The system considers reviews open until the Next Review Date field is updated.</td>
</tr>
<tr>
<td>Review Forms for Reviews Due</td>
<td>This report lets you view employee job and salary history. It also provides a section of requested changes for the reviewer to fill out and management to sign. The options are identical to those</td>
</tr>
<tr>
<td><strong>Report Name</strong></td>
<td><strong>Report Description</strong></td>
</tr>
<tr>
<td>----------------</td>
<td>------------------------</td>
</tr>
<tr>
<td>Salary Analysis by Employee Name</td>
<td>The Salary Analysis by Employee Name report lets you evaluate salaries categorized by individual employees, job title, all employees, or your own search criteria. This report includes pay rates, hours, annual salaries, longevity, and compa-ratio.</td>
</tr>
<tr>
<td>Salary Analysis by Job Code</td>
<td>The Salary Analysis by Job Code Report lets you evaluate salaries by job code, individual employee, all employees, or your own search criteria. This report includes job titles, salary grades, pay rates, annual salaries, and other data. It is sorted by exempt and nonexempt employees.</td>
</tr>
<tr>
<td>Salary Analysis by Job Title</td>
<td>The Salary Analysis by Job Title Report lets you evaluate salaries by job title, job code, individual employee, all employees, or your own search criteria. This report includes pay rates, hours, annual salaries, longevity, compa-ratio, and other data.</td>
</tr>
<tr>
<td>Salary Analysis by Organization</td>
<td>This report lists employees’ salaries by organization level. The employee’s pay rate, hours, annual salary, years of service, rating, and compa-ratio are listed. The employees’ average annual salary, total annual salary, and number of employees are totaled for the organization level as well as for the entire employer at the end of the report.</td>
</tr>
<tr>
<td>Salary Analysis by Salary Grade</td>
<td>The Salary Analysis by Salary Grade Report lets you evaluate salaries by salary grade, individual employee, all employees, or your own search criteria. This report includes job titles, salary grades, pay rates, annual salaries, and other data. The report averages and totals the annual salaries for each salary grade.</td>
</tr>
<tr>
<td>Salary As Of</td>
<td>Use this report to view a list of employees and their respective salaries at a given point in time. The report lists the employee name, job title, unit pay rate, and annual salary as of the selected date, the total of the salaries displayed and a calculated salary average. You can select individual employees, all employees, or define your own search criteria.</td>
</tr>
<tr>
<td>Salary Grade Range Exceptions</td>
<td>Use this report to generate a list of employees whose rate of pay is different (more or less) from their assigned salary grade range. This report works only if Salary Grade Validation is enabled during setup of Sage Abra SQL HRMS. Grouped by organization levels, the report lists employee, title, salary, normal salary grade range (minimum and maximum), and the difference in dollar amount between the salary grade range and what the employee is paid.</td>
</tr>
<tr>
<td>Salary History</td>
<td>Use this report to produce an employee compensation history. It lists employees, effective dates, reasons for change, salary rates, and annual salaries.</td>
</tr>
<tr>
<td>Salary Increase Analysis by Job Code</td>
<td>The Salary Increase Analysis by Job Code report lets you evaluate salary increases by job code. This report includes previous versus current salaries, effective dates, reasons for adjustments, and actual and percentage amounts of increases.</td>
</tr>
<tr>
<td>Salary Increase Analysis by Organization</td>
<td>Use this report to analyze employee salary increases by organization level. The report includes previous versus current salaries, effective dates, reasons for adjustments, and actual and percentage amounts of increases.</td>
</tr>
</tbody>
</table>
Report Name | Report Description
---|---
Salary Increase Analysis by Reason | Use this report to analyze employee salary increases by reason. The report includes previous versus current salaries, effective dates, reasons for adjustments, and actual and percentage amounts of increases.
Statistics by Job Code | This report groups statistical data into exempt and nonexempt employee categories. For each job code, the report shows titles, number of employees in each category, average unit rate, and average and total salaries.
Terminated Employee Log | This report lists terminated employees for a specified date range. It searches the Employee Status field for all employee records tagged as terminated. The report provides dates of hire and termination, name, employee number, reason for termination, title, organization levels, employee type, longevity, pay rate and frequency, and annual salary. It sorts the records by termination date, gives a headcount and calculates average and total terminated salaries.
Turnover Performance vs. Longevity Matrix | This report provides information about turnover rate within your organization. It might indicate a problem if employees with a high performance rating consistently leave your company, while poor performers have remained with the company a long time. The matrix lists performance ratings vs. length of time employed for terminated employees.
Turnover Statistics | This report lets you view turnover statistics and calculates service length by Adjusted Seniority Date, Original Hire Date, or Last Hire Date. For each terminated employee, this report includes termination type, termination date, employee name, title, service length, salary grade, and termination reason.

EEO Reports

EEO reports help you track an employer’s compliance in its hiring practices.

Report Name | Report Description
---|---
EEO-1 Headcount Summary | This report is a table showing EEO classifications and the number of employees in each classification. The table is broken down by gender and ethnic origin. Each column is totaled. On the Specific Criteria tab for this report, you can enter the previously reported totals you want to appear in Section D, line 11. After you print or preview the report, the system asks if you want to save the new totals as the previous totals. Click Yes if you want the totals on the current report to be saved as the Previous Reported Totals on the Specific Criteria tab for the next time you run the report.
EEO-1 Headcount Detail | The EEO-1 Headcount Detail report gives you a list of employees grouped by EEO classification, which enables you to reconcile the information generated in the EEO Headcount Summary report.
EEO-4 Headcount Summary | This report is a table showing EEO classification, annual salaries, and the number of employees in each classification. The table is broken down by gender and ethnic origin. Each
## Report Name | Report Description
--- | ---
EEO-4 Headcount Detail | This report lists employees grouped by EEO classification, which lets you reconcile with the information generated in the EEO Headcount Summary. This EEO-4 report consists of multiple pages.
EEO Job Group Age Analysis | This matrix indicates the number of employees from specific age groups falling within each EEO job group. In addition to assisting you with ADEA compliance, this report also helps you analyze your work force and helps you plan for groups of employees who are approaching retirement.
EEO Job Group Headcount | This report indicates the number and percentage of employees in each gender and ethnic group who fall within specific EEO job groups.
EEO New Hire Headcount Summary | This summary provides a table showing EEO classifications and the number of new hire employees in each. The summary is broken down by gender and ethnic origin.
EEO New Hire Headcount Detail | This report gives you a list of new hire employees grouped by EEO classification.
EEO Termination Summary | This summary provides a table of EEO classifications and the number of terminated employees in each classification. The summary is broken down by gender and ethnic origins.
EEO Termination Detail | This report provides a list of terminated employees grouped by EEO classification.
I-9 Citizenship Verification | This report provides a list of employees and their I-9 citizenship status and renew dates.
Promotions Report | The Promotions report includes the EEO class codes, genders, and ethnic backgrounds of employees promoted within a specific time.
Veterans Employment | This table shows EEO classifications (job categories) and the number of employees and new hires in each classification. The table is broken down by veteran status.
**Note:** Sage Abra SQL HRMS adds the number of employees in EEO Class 1.1 (Executive/Senior Level Officials and Managers) with the number of employees in EEO Class 1.2 (First/Mid Level Officials and Managers). The total is displayed on the report as EEO Classification Code 1 (Officials and Managers).
Vets 100 Detail List | This report provides employee names and IDs by job category for each VETS-100 category. The report includes newly hired veterans by category and total new hires for the twelve (12) month period specified.
Vets 100 Summary | This report provides the number of employees by job category for each VETS-100 category.
**Employment Equity Reports**

Employment Equity reports help you track an employer’s compliance in its hiring practices. These reports list employees based on the last activity that took place. For example, if you enter a date range of 1/1/2008 through 12/31/2008 and during that time Donald Adams was hired, terminated, and then rehired, the report would show Donald Adams as an active employee because the last activity was that he was rehired.

<table>
<thead>
<tr>
<th>Report Name</th>
<th>Report Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>EE 1 Audit: Summary</td>
<td>This report lists employees by designated CMA, employment status, industrial sector, and province.</td>
</tr>
<tr>
<td>EE 2 Audit: Salary Summary</td>
<td>This report lists employees by industrial sector, province, salary, and gender.</td>
</tr>
<tr>
<td>EE 3 Audit: Occupational Group</td>
<td>This report lists employees by province, CMA, salary, employee name and ID, number of active and inactive employees, and total number of employees by gender.</td>
</tr>
<tr>
<td>EE 4 Audit: Hired</td>
<td>This report displays information for new employees hired between a selected from and to date.</td>
</tr>
<tr>
<td>EE5 Audit: Promoted</td>
<td>This report displays information for employees promoted between a selected from and to date. Note that only employees whose change reason code is Promo are included in the report. If you set up a code for promotions other than Promo, employees will not be included on the report.</td>
</tr>
<tr>
<td>EE 6 Audit: Terminated</td>
<td>This report displays information for employees who were terminated between a selected from and to date.</td>
</tr>
</tbody>
</table>
Employee and Organization Reports

Employee and organization reports include lists of anniversary dates, personnel events, organizational structure, years of service, business telephone directory, and recruiting and union activity.

<table>
<thead>
<tr>
<th>Report Name</th>
<th>Report Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Anniversary List</td>
<td>The Anniversary List indicates hire dates and seniority rankings for individual employees, all employees or your own reporting criteria during one month or all months, as of the effective date you specify. You can base the anniversary date on the last hire date, original hire date, or seniority date. Sort the report by anniversary date, employee name, anniversary date by organization level, and employee name by organization level.</td>
</tr>
<tr>
<td>Event Report</td>
<td>Use this report to print a list of employee events. Events are training, licenses, bonuses, professional memberships, company cars, or anything defined in the Events code table. You can select a specific event or report all events, as well as specify a date range for next due (renewal) dates. The report lists employee, title, organization levels, event code, effective date, event description, next due date, and comments.</td>
</tr>
<tr>
<td>New Hire Log</td>
<td>This report lists all employees hired during the date range you specify. You can select to include or exclude rehires, and you can choose to sort by employee name or date hired.</td>
</tr>
<tr>
<td>Organizational Report</td>
<td>This report is a list of employees grouped by organizational levels and supervisors. Each group includes employee name, ID number, title, job code, seniority date, and employee type (such as RFT or RPT). An employee count is subtotaled by organization levels. An employee total ends the report.</td>
</tr>
<tr>
<td>Recruiter Activity</td>
<td>Select this report to review recruiter activity during a specified time period. For each recruiter, the report identifies new recruits, their current jobs, organization levels, and dates of hire.</td>
</tr>
<tr>
<td>Service List</td>
<td>This report provides a list of employees based on years of service. This list includes years of service, seniority dates, employee names, titles, and organization levels. It gives the employee headcount from which it calculates the average length of service.</td>
</tr>
<tr>
<td>Source-of-Hire Activity</td>
<td>This report indicates the sources of new hires during the time period you specify. The report pinpoints new employees referred by personnel agencies, classifieds, recruiters, and all other sources.</td>
</tr>
<tr>
<td>Telephone Directory</td>
<td>This report provides a telephone directory for all employees and organization levels. You can also build your own reporting criteria. Select to display the full ten-digit number, an extension number, or both numbers. You can even include employees without phone numbers. This report uses the Nickname field from the Demographics page as the employee’s first name; if this field is blank, the report uses the First Name field; if this field is blank, the report prints the Last Name but leaves the Nickname/First Name blank on the report.</td>
</tr>
<tr>
<td>Union Report</td>
<td>This report lists employees who belong to unions. The report provides an alphabetical listing of employees sorted by name and includes employee titles, longevity, salaries, and union sign-up</td>
</tr>
</tbody>
</table>
Leave Reports

Sage Abra SQL HRMS includes reports to help you track and monitor employees’ leaves of absence.

<table>
<thead>
<tr>
<th>Report Name</th>
<th>Report Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Employees Currently on FMLA</td>
<td>This report indicates all employees currently on FMLA leave. The report includes the FMLA event and the starting and ending dates. You can include selected employees, selected organization levels, or a particular exempt status.</td>
</tr>
<tr>
<td>Employees Currently on LOA</td>
<td>This report indicates all employees currently on leave. The report includes the leave reason and the starting and ending dates. You can include selected employees, selected organization levels, or a particular exempt status.</td>
</tr>
<tr>
<td>FMLA Due to Return</td>
<td>This report indicates all employees scheduled to return from FMLA leave. The report includes the FMLA event and the starting and ending dates. You can include selected employees, selected organization levels, or selected exempt status.</td>
</tr>
<tr>
<td>LOA History</td>
<td>This report displays employees whose LOA start date is within the date range you select. It is grouped and sorted by employee name and displays status, leave reason, and the start and actual return dates.</td>
</tr>
<tr>
<td>Medical Recertification</td>
<td>This report lists employees due for medical recertification prior to returning from FMLA leave. The report includes the FMLA event and the starting and recertification dates. You can include selected employees, organization levels, or exempt status.</td>
</tr>
</tbody>
</table>

OHS Reports

The information on Occupational Safety and Health (OSH) reports comes from the information provided on the OHS page.

<table>
<thead>
<tr>
<th>Report Name</th>
<th>Report Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accident Analysis by Injury</td>
<td>This report shows the number of work-related injuries or illnesses and the impact of related medical costs and lost productivity on the organization due to these incidents. Events are sorted by injury.</td>
</tr>
<tr>
<td>Accident Analysis by Location</td>
<td>This report lists the number of work-related injuries or illnesses and the impact of related medical costs and lost productivity on the organization due to these incidents. These events are sorted by location.</td>
</tr>
<tr>
<td>Accident Analysis</td>
<td>This report shows the number of work-related injuries or illnesses and the impact of related...</td>
</tr>
</tbody>
</table>
### Report Name | Report Description
--- | ---
by Organization Level  | medical costs and lost productivity on the organization due to these incidents. Events are sorted by organization level.
Accidents by Date | Use this report to view by date the number and nature of work-related injuries, illnesses or first aid administered within the time period you specify. You can print this report for individual employees, for all employees, or with your own reporting criteria. You can also include or exclude information regarding unfiled accidents and closed accidents.
Accidents by Employee | You can print this report to view the number and the nature of work-related injuries or illnesses within the time period you specify, sorted by employee. You can print this report for individual employees, for all employees, or with your own reporting criteria.
Accidents Not Filed | This report indicates work-related injuries or illnesses not filed during the time period you specify. Like the Accidents by Employee Report, this report can be printed for individual employees, for all employees, or with your own reporting criteria.
WSIB - Employers Report Form | Use this form to report a work related accident or illness to the Workplace Safety and Insurance Board.
Workers' Compensation Open Claims | Use this report to view the number of open Workers' Compensation claims. The report includes the number and the nature of open cases, the dates claims were filed and closed, the case numbers and claim IDs and the number of work days the employee lost, or experienced restricted duty.

### OSHA Reports

The information in Occupational Safety and Health Act (OSHA) reports comes from the information provided on the OSHA page.

### Report Name | Report Description
--- | ---
Accident Analysis by Injury | This report shows the number of work-related injuries or illnesses and the impact of related medical costs and lost productivity on the organization due to these incidents. Events are sorted by injury.
Accident Analysis by Location | This report lists the number of work-related injuries or illnesses and the impact of related medical costs and lost productivity on the organization due to these incidents. These events are sorted by location.
Accident Analysis by Organization Level | This report shows the number of work-related injuries or illnesses and the impact of related medical costs and lost productivity on the organization due to these incidents. Events are sorted by organization level.
Accidents Not Filed | This report indicates work-related injuries or illnesses not filed during the time period you
<table>
<thead>
<tr>
<th>Report Name</th>
<th>Report Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use Displays</td>
<td>Displays detailed information about employees’ work-related accidents. This report includes other information such as hospital details.</td>
</tr>
<tr>
<td>Displays</td>
<td>Use this report to view by date the number and nature of work-related injuries, illnesses or first aid administered within the time period you specify. You can print this report for individual employees, for all employees, or with your own reporting criteria. You can also include or exclude information regarding unfiled accidents and closed accidents.</td>
</tr>
<tr>
<td>Displays</td>
<td>You can print this report to view the number and the nature of work-related injuries or illnesses within the time period you specify, sorted by employee. You can print this report for individual employees, for all employees, or with your own reporting criteria.</td>
</tr>
<tr>
<td>OSHA 101 Accident Profile</td>
<td>Displays detailed information about employees’ work-related accidents. This report includes other information such as hospital details.</td>
</tr>
<tr>
<td>OSHA 200 Log</td>
<td>Displays a log and summary of occupational injuries and illness. This report does not include a total.</td>
</tr>
<tr>
<td>OSHA 300 Incident Log</td>
<td>Displays a log of the number of work-related illnesses and injuries sustained by employees within a given time period.</td>
</tr>
<tr>
<td>OSHA 300A Summary of Work-Related Injuries and Illnesses</td>
<td>The OSHA 300A report indicates the number of work-related illnesses and injuries sustained by employees within a given time period. You can sort data according to incident type and print either summary or detail reports. Summary reports contain those totals you must post by law. Detail reports contain information to help you reconcile totals in the summary reports.</td>
</tr>
<tr>
<td>OSHA 301 Incident Report</td>
<td>This report summarizes work-related injuries and illnesses, including company and home contact information, incident information, and other details.</td>
</tr>
<tr>
<td>Workers’ Compensation Open Claims</td>
<td>Use this report to view the number of open Workers’ Compensation claims. The report includes the number and the nature of open cases, the dates claims were filed and closed, the case numbers and claim IDs, and the number of work days the employee lost or experienced restricted duty.</td>
</tr>
</tbody>
</table>

**Pay Equity Reports**

The information on these reports comes from the information provided on the Pay Equity page. These reports assist with the process of determining male and female dominated jobs within an organization.

<table>
<thead>
<tr>
<th>Report Name</th>
<th>Report Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Job Groups by Gender</td>
<td>This report lists employees by gender within a job and job group. This information assists with the process of company jobs for pay equity purposes.</td>
</tr>
</tbody>
</table>
## Personal Information Reports

Personal information includes lists of birthdays, addresses and telephone numbers, mailing labels, headcounts, and detailed employee profiles.

<table>
<thead>
<tr>
<th>Report Name</th>
<th>Report Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jobs by Gender</td>
<td>This report lists the employees by gender within a job. This information assists with the process of determining male and female dominated jobs within an organization.</td>
</tr>
<tr>
<td><strong>Personal Information Reports</strong></td>
<td></td>
</tr>
<tr>
<td>Age List</td>
<td>This report lets you view a list of employees sorted by age. The report includes employee birth dates, titles, divisions, and departments.</td>
</tr>
<tr>
<td>Birthday List</td>
<td>Select this report to view a list of employee birthdays. You can sort the list by date, name, by date for each division and department, and by name for each division and department. You can print the list for any or all months and you can choose whether or not to include address information.</td>
</tr>
<tr>
<td>Employee Attachments</td>
<td>Use this report to list the attachment records for a selected group of employees. An option is also available to show which employees are missing required attachments.</td>
</tr>
<tr>
<td>Employee Count</td>
<td>This report is a count of all employees within your organization. By defining the appropriate selection options, you can count all the employees within your company, within a division, and within a department.</td>
</tr>
<tr>
<td>Employee List</td>
<td>The Employee List lists employee information by last name, first name, and middle initial. It contains employee IDs, titles, and organization levels.</td>
</tr>
<tr>
<td>Employee Notes</td>
<td>Use this report to print notes for the employees you specify. You can choose to print all notes or only those of a particular type or by a particular author. You can sort by employee name, note type, author, comment date, or follow-up date.</td>
</tr>
<tr>
<td>Employee Profile</td>
<td>The Employee Profile report compiles employee information. Use this report to print a profile for an individual, all employees, or your own criteria. Customize your profile by selecting the employee pages from which the system pulls information.</td>
</tr>
<tr>
<td>Home Mailing Labels</td>
<td>This report provides employees’ names and addresses printed in three-column label format (30 labels per page). You can sort these by employee name, employee ID, or zip code and employee name. If sheets of labels don’t move easily through your printer, try printing the labels on regular paper, then use your copier.</td>
</tr>
<tr>
<td>Work Phone List</td>
<td>This report lists employees’ names and work telephone numbers. It displays the standard ten-digit phone number (including the area code), the extension number and the organization levels for each employee.</td>
</tr>
</tbody>
</table>
Skill and Education Reports

These reports help you track and record the skill sets and educational background of your employees.

<table>
<thead>
<tr>
<th>Report Name</th>
<th>Report Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Education Report</td>
<td>Lists education information for all employees in the selected employer.</td>
</tr>
<tr>
<td>License/Certificate</td>
<td>Lists all licensed and certified employees in the selected employer, including effective dates and due dates.</td>
</tr>
<tr>
<td>Membership List</td>
<td>Lists all employee memberships, including effective dates and due dates.</td>
</tr>
<tr>
<td>Previous Experience</td>
<td>Allows you to review each employee’s previous work experience, including from and to dates and previous salaries.</td>
</tr>
<tr>
<td>Skill Retrieval Report</td>
<td>This report lets you view a list of employees who have a specific skill set for which you are looking. For the skill you specify, the report includes each employee’s title, organization level, and date of hire.</td>
</tr>
<tr>
<td>Skill and Education List</td>
<td>This report provides an alphabetized list of individual employees, all employees or the reporting criteria you specify. The report includes each employee’s skills, years of experience in each skill and a comment area that provides short details about each skill. In addition, the report indicates schools attended, attendance duration, grade point averages, and scholastic degrees earned.</td>
</tr>
<tr>
<td>Skills Report</td>
<td>Lists skills for all employees in the selected employer, including specialized skills such as foreign languages.</td>
</tr>
</tbody>
</table>

Wellness Reports

The information on these reports comes from the information provided on the Wellness page.

<table>
<thead>
<tr>
<th>Report Name</th>
<th>Report Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blood Donor List</td>
<td>This report lists each employee’s department and division, blood type, RH factor, and last donation date. It also provides the employee’s telephone extension. You can select to print specific blood types or all records as of a specified date.</td>
</tr>
<tr>
<td>Drug Tests Due</td>
<td>The information on this report includes the employee’s name, date of the most recent drug test, its result, the date of the next test, the number of years since the last test and the telephone extension.</td>
</tr>
<tr>
<td>Emergency Contacts</td>
<td>This report provides a list of employees and their emergency contacts.</td>
</tr>
</tbody>
</table>
### Time Off Reports

The following reports provide information about employee absences and attendance benefits:

<table>
<thead>
<tr>
<th>Report Name</th>
<th>Report Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Absence Averages</td>
<td>Abra Attendance sorts this report by organization level and absence reason code. For each absence reason, the report provides statistics on the average number of absences per employee. You can specify a date range for the report as well as show averages for only one absence reason code or all codes.</td>
</tr>
<tr>
<td>Absence Log</td>
<td>The Absence Log replaces the manual attendance card. For each employee, this report lists the absence reason codes the employee has on record along with the date, weekday, number of hours, and comments regarding each absence. You can select one employee or a group of employees, include one or all absence reason codes, and specify a date range for the report. You can sort by Employee Name or ID.</td>
</tr>
<tr>
<td>Absence Percentages by Department</td>
<td>This report, sorted by organization level, helps you analyze the reason for absences within given departments. For each weekday, the report shows the percentage of absences for each Absence Reason. The % of Reason column indicates the percentages for each reason within an organization level for all weekdays. The % of Company column shows the percentage of absences for each reason and organization level within the entire employer. This totals 100% for the employer. You can specify a date range for the report.</td>
</tr>
<tr>
<td>Absence Percentages by Reason</td>
<td>This report compares the departmental absences for each Reason code. For every day of the week, this report indicates the percentage of absences in each department for each reason. The % of Org column shows the percentage of absences for each organization level and every day of the week. The % of Company column shows the percentage of absences for each organization level and reason within the entire employer. This totals 100% for the employer. You can specify a date range for the report.</td>
</tr>
<tr>
<td>Absence Points</td>
<td>This report includes all employees who fall within a specified range of absence points from the threshold value established for each attendance plan. Use this report to spot employees who exceed your employer’s threshold values. You can specify selected employees or employee groups, a date range for the report and the number of points from the threshold value.</td>
</tr>
</tbody>
</table>

---

**Report Name** | **Report Description**  
--- | ---  
Health Profile | This profile provides an overall view of the employee’s health. Some examples of the type of information provided include allergies, chronic conditions, wellness programs, blood type and eligibility for donation date, height, and weight.  
Physical Exams Due | The Physical Exams Due report provides the date of the employee's last physical exam, the result of that physical, the date of the next physical, the number of years since the last physical and the telephone extension.
<table>
<thead>
<tr>
<th>Report Name</th>
<th>Report Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Abra Attendance</strong></td>
<td>Abra Attendance calculates the <strong>Over</strong> column (number of points over threshold ) as absence points minus the threshold value.</td>
</tr>
<tr>
<td><strong>Employee Year-To-Date Attendance</strong></td>
<td>This report shows a summary of attendance information for each plan, including carryover hours, hours accrued, hours taken, and hours available. It also lists absences chronologically for each plan. If an employee has zero hours available for a plan, the plan does not appear on the report. You can select specific employees, employee groups and organization levels, enter a date range for the absences and choose whether or not to include absence comments.</td>
</tr>
<tr>
<td><strong>Employee Year-To-Date Attendance Totals</strong></td>
<td>Use this report to view a summary of hours accrued, taken and available as of the current accrual date. For each employee, Abra Attendance lists the totals for every attendance plan. You can include selected employees or employee groups, organization levels, and employees of a specific exempt status.</td>
</tr>
<tr>
<td><strong>Employees Currently on FMLA</strong></td>
<td>This report includes leave statistics on all employees who have been assigned an FMLA Leave of Absence and have not yet returned to work. Abra Attendance sorts the report by organization level and includes the leave type, the FMLA event, the date the leave started, and the scheduled return date. You can include selected employees or employee groups, organization levels, and employees of a specific exempt status.</td>
</tr>
<tr>
<td><strong>FMLA Due to Return</strong></td>
<td>This report indicates all employees scheduled to return from FMLA leave. The report includes the leave type, the FMLA event, the date the leave started, and the scheduled return date. You can include selected employees or employee groups, organization levels, and employees of a specific exempt status.</td>
</tr>
<tr>
<td><strong>Medical Recertification</strong></td>
<td>This report lists employees due for medical recertification before returning to work from an FMLA leave of absence. The report is sorted by organization level and includes the leave type, the FMLA event, the date the leave started, and the recertification date. You can include selected employees or employee groups, organization levels, and employees of a specific exempt status.</td>
</tr>
<tr>
<td><strong>Perfect Attendance</strong></td>
<td>This report lists all employees who have perfect attendance records within a specified date range. Abra Attendance calculates years of service for each employee as of the <strong>Seniority Start Date</strong> on the employee’s HR Status page. You can select one or a group of employees, specific organization levels, employees of a particular exempt status, and absence transactions within a specified date range.</td>
</tr>
<tr>
<td><strong>Previous Year End Totals</strong></td>
<td>For each employee and each attendance plan, this report provides the carryover hours, hours accrued, hours taken, and hours available as of the previous plan year close date. It also totals the attendance information for all plans combined. You can include specific employees or employee groups, specific organization levels, and employees of a particular exempt status.</td>
</tr>
<tr>
<td><strong>Ranked List by Hours Absent</strong></td>
<td>For each employee, this report shows the total number of absence hours taken for each absence reason. The system groups the report by reason code and lists the employees within each reason code. You can select specific employees or groups of employees, specific organization levels, and employees of a particular exempt status.</td>
</tr>
</tbody>
</table>
**Code Table Reports**

Review all the defined codes in your code tables by printing your code table reports. Use these reports as a reference before or after updating your code tables for the enterprise or each employer.

Sage Abra SQL HRMS provides the following code table reports:

- Aboriginal Codes
- Attachment Codes
- Benefit Insurance Plans
- Benefit Rate Tables
- Benefit Savings Plans
- Benefit Type Codes
- Census Metro Area Codes
- Consent Types
- Dependent Relationship Codes
- Direct/Indirect Codes
- Disability Codes
- EE Category Codes
- EE Occupational Group Codes
- EEO Classification Codes
- EEO Job Group Codes
- EEO-4 Job Function Codes
- Employee Note Author Codes
- Employee Note Type Codes
- Employee Type Codes
- Ethnic ID Codes
- Event Codes
- FMLA Event Reason Codes
- Industrial Sector Codes
- Job Classification Codes
- Job Codes
- Job Family Codes
- Job Status Codes
- Language Codes
- NOC Occupation Group Codes
- OHS Body Part Codes
- OHS Injury Codes
- OHS Injury Location Codes
- OSHA Body Part Codes
- OSHA Injury Codes
- OSHA Injury Location Codes
- Organization Codes
- Pay Equity Job Group Codes
- Rating Codes
- Reason Codes
- Salary Grades
- Shift Differential Codes
- Skill Codes
- State/Province Codes
- Step Rate Codes
- Union Codes
- User-Defined Codes
- Visible Minority Codes

Sage Abra SQL HRMS also provides the following code table reports for Time Off:

- Absence Reason Codes
- FMLA Event Reason Codes
Sage Abra SQL HRMS includes many Payroll reports that are grouped into the following categories:

- Bank Reports
- Employee Reports
- Government Reports
- Periodic Processing Reports
- Setup Reports
- Tax Reports
- Transaction Reports

You can access Payroll reports by selecting **Reports > Payroll** on the Navigation Pane. Sage Abra SQL HRMS includes many Payroll reports that are grouped into the following categories:

- Bank Reports
- Employee Reports
- Government Reports
- Periodic Processing Reports
- Setup Reports
- Tax Reports
- Transaction Reports

You can access Payroll reports by selecting **Reports > Payroll** on the Navigation Pane.

**Bank Reports**

Bank reports include information to assist you in managing your company’s bank accounts, setup options, transactions, and in reconciling bank accounts.

<table>
<thead>
<tr>
<th>Report Name</th>
<th>Report Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bank Entries Posting Journal</td>
<td>A printed record of bank entries that were posted together. This report provides an audit trail of transactions posted using bank services by posting sequence.</td>
</tr>
<tr>
<td>Bank Reconciliation</td>
<td>Displays the result of the last posted bank reconciliation for each bank included in the report. It explains the difference between the bank statement and your company records.</td>
</tr>
<tr>
<td>Report Name</td>
<td>Report Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Banks</td>
<td>Lists the bank records defined for your company, which includes G/L account and other information about each bank. Print this report after you add, change, or delete bank records.</td>
</tr>
<tr>
<td>Check Payment</td>
<td>Lists all payments made from a bank account. Use this report to view or print payments made from a particular bank for a specified period of time.</td>
</tr>
<tr>
<td>Register</td>
<td></td>
</tr>
<tr>
<td>Credit Card Types</td>
<td>Displays codes and descriptions for the credit cards you entered (using the Credit Card Types page), each card’s status (Active or Inactive), and the date when it was last maintained.</td>
</tr>
<tr>
<td>Deposit Register</td>
<td>Lists all deposits to a bank account. Use this report to view or print deposits that were made to a bank or a range of banks over a specified period of time.</td>
</tr>
<tr>
<td>Deposits Status</td>
<td>Lists all deposits (including transfers) that are currently in transit for the bank account being reconciled.</td>
</tr>
<tr>
<td>Distribution Codes</td>
<td>Lists the account distribution codes defined for bank transactions. Print this report after you add, change, or delete distribution codes.</td>
</tr>
<tr>
<td>G/L Integration</td>
<td>Displays the options you selected on the Bank G/L Integration page, including when to create G/L batches (for example, during posting), how to create G/L transactions (for example, by creating a new batch), and whether to consolidate G/L batches.</td>
</tr>
<tr>
<td>G/L Transactions</td>
<td>Lists the general ledger transactions created from all posted transactions. Use this report as your audit trail for generated general ledger transactions.</td>
</tr>
<tr>
<td>Options</td>
<td>Lists the options you selected on Bank Options page. Print the report after bank setup and when you change bank options. This report displays the transfer adjustment account number, the next posting sequence number, and the next transfer number.</td>
</tr>
<tr>
<td>Reconciliation</td>
<td>This report is an audit trail of all transactions posted during bank reconciliation. It includes checks and deposits that cleared the bank, as well as entries that Sage Abra SQL HRMS created to account for clearing differences and bank errors.</td>
</tr>
<tr>
<td>Posting Journal</td>
<td></td>
</tr>
<tr>
<td>Reconciliation</td>
<td>Lists the status and amounts of all transactions for a bank account.</td>
</tr>
<tr>
<td>Status</td>
<td></td>
</tr>
<tr>
<td>Transaction Listing</td>
<td>Lists all transactions recorded for one bank or for a range of banks.</td>
</tr>
<tr>
<td>Transfer Posting</td>
<td>This report is an audit trail of all transactions posted during bank transfers. It includes payments and deposits transferred between banks, transfer charges and transfer charge adjustments, as well as tax information (optional).</td>
</tr>
<tr>
<td>Journal</td>
<td></td>
</tr>
<tr>
<td>Withdrawals Status</td>
<td>Lists all outstanding checks and transfers from a bank or a range of banks.</td>
</tr>
</tbody>
</table>
**Employee Reports**

Employee (Payroll) reports include information to assist you in managing payroll for your employees.

<table>
<thead>
<tr>
<th>Report Name</th>
<th>Report Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assign Employee Earn/Ded Audit</td>
<td>Lists the information that you entered on the Assign Employee Earnings/Deductions page.</td>
</tr>
<tr>
<td>Employee Information</td>
<td>Lists the information you entered for the selected employees on the Employees page.</td>
</tr>
<tr>
<td>Employee Selection</td>
<td>Lists the information you entered on the Employee Selection page for the specified selection list codes. This includes the employee number, employee name, pay frequency, and status.</td>
</tr>
<tr>
<td>Employee Supplemental Info</td>
<td>Displays the information you entered on the Employee Supplemental Information page.</td>
</tr>
<tr>
<td>Transaction History</td>
<td>Lists all transactions (in detail or summary form) during the selected period for employees.</td>
</tr>
<tr>
<td>Transaction History Audit</td>
<td>Lists the transaction history information entered for employees in Transaction History. This includes the employee name and number for which the transaction was entered, date and time when the transaction was last edited, the transaction date, a description of each transaction, and the amount of each transaction.</td>
</tr>
<tr>
<td>Update Employee Earn/Ded Audit</td>
<td>Lists the information that you entered on the Update Earn/Ded For All Employees page.</td>
</tr>
<tr>
<td>Update Employee Taxes Audit</td>
<td>Print this report after you use the Update Tax for All Employees function.</td>
</tr>
</tbody>
</table>

**General Ledger Reports**

General Ledger reports are those that provide you with transaction listings and status information (such as batch listings, posting journals, source journals, and the chart of accounts).

<table>
<thead>
<tr>
<th>Report Name</th>
<th>Report Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chart of Accounts</td>
<td>Lists all or a range of General Ledger accounts according to the selection criteria and the sort and format criteria you specify.</td>
</tr>
<tr>
<td>Source Journal</td>
<td>Lists the details of posted transactions for the source codes that you included in the source-journal definition, and in the order you specify at print time.</td>
</tr>
</tbody>
</table>
### Government Reports

**Report Name** | **Report Description**
---|---
Account Groups | Displays account group codes, sort codes, and descriptions.
Segment Code | For each G/L segment, the report lists all or a range of codes defined for the segment, together with the code descriptions and the numbers and descriptions of the retained earnings accounts to which the segment codes are closed.
Account Structures | This report lists the account structure codes in the selected range, description for each code, and the segments included in each account structure, in the order they appear.
Source Code | Lists a range of source codes, along with the description entered in the Source Codes window for each code. Source codes add flexibility to your General Ledger, because you define them. You can select and print lists of posted transaction details by source codes, using the Source Journal report from the G/L Reports folder.
Source Journal Profile | Lists all or a range of the source journal definitions that have been added to the ledger. Source journals allow you to list posted transactions that were entered with particular source codes. The source journal lists the source codes that are included in the journal, as well as the default report that’s used to print the journal.
Options | This report lists the options selected and information entered on the G/L Options window, including the account-number segments defined for your ledger and the descriptions associated with those segments, and posting preferences.
Optional Fields | Lists all the optional fields set up for your General Ledger. The report lists separately the optional fields set up for accounts and transaction details. For each optional field code, the report shows the description, default value, whether the optional field is required, and whether the optional field is set for automatic insertion in new accounts.

### Government Reports

Government reports include information required to report payroll details to the government.

**Report Name** | **Report Description**
---|---
941 | Displays totals of wages paid subject to federal income tax withholding and income tax withheld in the quarter, total of net federal withholding and employee/employer Social Security/Medicare tax liability for the quarter and other required information.
Quarterly Wage | Print this report to provide quarterly wage reports for your individual taxing authorities.
Quarterly Wage on Disk | Produces a quarterly wage data file on disk to be submitted to tax authorities, by electronic means where permitted.
Periodic Processing Reports

<table>
<thead>
<tr>
<th>Report Name</th>
<th>Report Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Quarterly Wage on Disk Status</td>
<td>Summarizes the data of the last Quarterly Wage on Disk run. The information included on this report depends on the state in which your company does business. This report does not generate a printed report on paper.</td>
</tr>
<tr>
<td>W-2s on Disk</td>
<td>Generates a W-2 data file (containing statements of employee earnings subject to federal, state, and other taxing authorities, for the year) to a disk. This report does not generate a printed report on paper. You can submit the file to tax authorities by electronic means (where permitted).</td>
</tr>
<tr>
<td>W-2s on Disk Status</td>
<td>Displays current run totals for all W-2 items that are applicable for all employees in the current run. Also displays totals for all the W-2 reports included on the disk or in the file.</td>
</tr>
<tr>
<td>W-2s on Paper</td>
<td>Prints W-2 data to a paper report.</td>
</tr>
</tbody>
</table>

**Periodic Processing Reports**

Periodic Processing reports allow you to review deleted inactive records and duplicate social security numbers.

<table>
<thead>
<tr>
<th>Report Name</th>
<th>Report Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete Inactive Records Audit</td>
<td>Lists the information deleted using the Delete Inactive Records page.</td>
</tr>
<tr>
<td>Duplicate SSN</td>
<td>Lists social security numbers that are assigned to more than one employee.</td>
</tr>
</tbody>
</table>

**Setup Reports**

Setup reports allow you to review the information you entered when setting up various Payroll features in Sage Abra SQL HRMS.

<table>
<thead>
<tr>
<th>Report Name</th>
<th>Report Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Class Codes</td>
<td>Lists the information entered for Class 1, Class 2, Class 3, and Class 4 in the Class Codes page. This includes the class codes and descriptions assigned to each class code.</td>
</tr>
<tr>
<td>Earnings and Deductions</td>
<td>You can print a report each for accruals, advances, benefits, deductions, earnings or expense reimbursements.</td>
</tr>
<tr>
<td>EFT Combine</td>
<td>Lists the companies that you have entered on the EFT Combine page.</td>
</tr>
<tr>
<td>EFT Options</td>
<td>Print the EFT Options setup report after setting up your EFT (direct deposit) options or whenever you want to verify the setup of the banks you use for direct deposit. This report lists</td>
</tr>
<tr>
<td><strong>Report Name</strong></td>
<td><strong>Report Description</strong></td>
</tr>
<tr>
<td>----------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>G/L Integration</td>
<td>Print this report to verify the information that you entered on the G/L Integration page.</td>
</tr>
<tr>
<td>Optional Fields</td>
<td>Print this report after setting up your optional fields or whenever you want to verify your optional fields setup.</td>
</tr>
<tr>
<td>Options</td>
<td>Lists the information you entered on the Options page including the years of history to keep, pay periods per year, hours per pay frequencies for each pay frequency, and integration options.</td>
</tr>
<tr>
<td>Overtime Schedules</td>
<td>Lists the information entered for the selected overtime schedules on the Overtime Schedules page.</td>
</tr>
<tr>
<td>Shift Differential Schedules</td>
<td>Lists the information entered for the selected shift differential schedules on the Shift Differential Schedules page including shift differential rates for Shift 1, Shift 2, Shift 3, and Shift 4.</td>
</tr>
<tr>
<td>Tax Profiles</td>
<td>Lists the information entered for the selected taxes on either the Federal and State Taxes page or the Local and Other Custom Taxes page. This includes W-2 reporting instructions, G/L distribution accounts, base earnings, base deductions, and associated taxes.</td>
</tr>
<tr>
<td>Work Classification Codes</td>
<td>Print the Work Classification Codes report after setting up or modifying your work classification codes.</td>
</tr>
<tr>
<td>Workers’ Compensation Codes</td>
<td>Lists the information entered for the workers’ compensation groups and codes on the Workers’ Compensation Codes page. This includes the workers’ compensation group, codes, descriptions, and rates (current and previous).</td>
</tr>
</tbody>
</table>

## Tax Reports

Tax reports allow you to review the information you entered when setting up Payroll taxes in Sage Abra SQL HRMS.

<table>
<thead>
<tr>
<th><strong>Report Name</strong></th>
<th><strong>Report Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Tax Authorities</td>
<td>Lists the tax authorities you defined for your company. You can generate this report after you add, modify, or delete tax authorities.</td>
</tr>
<tr>
<td>Tax Classes</td>
<td>Lists the sales or purchases tax classes you defined for your company. You can generate this report after you add, modify, or delete tax classes.</td>
</tr>
<tr>
<td>Tax Groups</td>
<td>Lists the tax groups you defined for your company. You can generate this report after you add, modify, or delete tax groups.</td>
</tr>
<tr>
<td>Tax Rates</td>
<td>Lists the tax rates you defined for your company’s sales and purchases. You can generate this report after you add, modify, or delete tax rates.</td>
</tr>
</tbody>
</table>
### Transaction Reports

Transaction reports allow you to review a variety of Payroll information such as employee earnings and hours and electronic funds transfer (EFT or direct deposit) transactions.

<table>
<thead>
<tr>
<th>Report Name</th>
<th>Report Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Report Name</strong></td>
<td>**Report Description</td>
</tr>
<tr>
<td><strong>Accruals</strong></td>
<td>For posted paychecks and entries made in transaction history, you can generate this report to display the hours and amounts that have been accrued and paid or as an accrual carry-over log that displays the accrual amounts or hours that were carried over to the start of a new accrual period.</td>
</tr>
<tr>
<td><strong>Earnings and Hours</strong></td>
<td>Displays employee hours and totals. The information Sage Abra SQL HRMS displays on this report varies according to your selected report options.</td>
</tr>
<tr>
<td><strong>Earnings/Deductions Summary</strong></td>
<td>Displays earning/deduction codes and their descriptions. The information Sage Abra SQL HRMS displays on this report varies according to your selected report options.</td>
</tr>
<tr>
<td><strong>EFT Combine History</strong></td>
<td>Lists the EFT combine files created.</td>
</tr>
<tr>
<td><strong>EFT Direct Deposit</strong></td>
<td>Print this report to verify the details of the EFT file that you generated before you submit the file to your bank.</td>
</tr>
<tr>
<td><strong>EFT Transactions</strong></td>
<td>Print this report to verify the details of paychecks that have been directly deposited. This report includes information about each direct deposit transaction such as the employee’s number and name, bank account information, paycheck number, and amount deposited.</td>
</tr>
<tr>
<td><strong>Employee Timecards</strong></td>
<td>Print this report to verify that employee timecards are complete and accurate before you calculate payroll.</td>
</tr>
<tr>
<td><strong>Hour Analysis</strong></td>
<td>Displays the hours (regular, overtime, shift) that were paid for each earning on an employee’s paycheck and the hours that were paid and accrued for each accrual on the paycheck.</td>
</tr>
<tr>
<td><strong>Manual Checks</strong></td>
<td>Allows you to generate a report on employee checks. This report includes information such as employee number and name, check date, check number, number of times the employee is deposited, and the amount deposited.</td>
</tr>
</tbody>
</table>

### Tax Tracking

Displays a complete list of tax amounts charged for taxable transactions since the last date on which tax information was reported and cleared. Use this report to complete reports required by government and as supporting documentation and to reconcile general ledger accounts. Print this report when you need tax information or at the end of reporting periods when you want to submit information to tax authorities.

after you add, modify, or delete tax rates.
<table>
<thead>
<tr>
<th>Report Name</th>
<th>Report Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Payroll G/L Transactions</td>
<td>Print this report before using Generate G/L Batch. This report includes only G/L transactions created on request using Generate G/L Batch. It does not include G/L transactions created during Payroll posting.</td>
</tr>
<tr>
<td>Payroll Processing Exceptions</td>
<td>Lists error conditions that Sage Abra SQL HRMS encounters during processing.</td>
</tr>
<tr>
<td>Payroll Register</td>
<td>Allows you to review payroll information. This report includes the check date, amount of checks, calculation sequence, posting sequence, employee numbers, names, social security numbers, times late, employee earnings/deductions and tax lists and more.</td>
</tr>
<tr>
<td>Pre-Check Payroll Register</td>
<td>Allows you to review the payroll register before generating checks.</td>
</tr>
<tr>
<td>Tax Calculation Analysis</td>
<td>Allows you to review tax information and totals by employee. The information Sage Abra SQL HRMS displays on this report depends on the report style you choose to generate.</td>
</tr>
<tr>
<td>Timecards</td>
<td>Allows you to review employee timecard information. This report includes employee numbers, names, timecard numbers, descriptions, statuses, earning/deduction information entered for the pay period, tax overrides for the pay period, total hours for regular and shift earnings, total amounts for vacation, sick, and compensatory time paid and more.</td>
</tr>
<tr>
<td>Workers’ Compensation</td>
<td>Allows you to review workers’ compensation information. The information Sage Abra SQL HRMS displays on the report includes worker’s compensation group, code, description, rate, employee total pay, excess earnings, assessable earnings, worker’s compensation code totals, company totals and more. The information Sage Abra SQL HRMS displays on this report depends on the report style you choose to generate.</td>
</tr>
</tbody>
</table>
Training reports are grouped into the following categories:

- Catalogs and Code Tables
- Class Administration Reports
- Employee Training Reports
- Training Analysis Reports

**Catalogs and Code Tables**

Review all the defined codes in your code tables by printing your code table reports. Use these reports as a reference before or after updating your code tables for the enterprise or each employer.

Abra Train provides the following code table reports:

- Certification Codes
- Class Ratings
- Course Catalog
- Course Types
- Enrollment Status Codes
- Instructor Catalog
- Instructor Ratings
- Job Codes
- Job Requirements
- Organization Codes
- Priority Codes
- State / Province Codes
- Training Locations
- Training Programs
- User-Defined Codes
Class Administration Reports

The Class Administration reports allow you to track classes and participants as well as generate class enrollment and completion letters.

Class Completion Letters

This report prints the Class Completion Letters for all employees that have completed a selected class or group of classes. Each letter prints on a separate page and includes the following letter sections:

- Enterprise Logo
- Enterprise Name
- Current Date
- Employee Information
- Greeting, Introduction
- Class Information
- Closing

You can select to include or exclude any of these sections or change their content by using the Edit Class Correspondence action. You can select to include employees with a particular enrollment status.

Class Enrollment Letters

This report prints the Class Enrollment Letters for all employees that are enrolled in a selected class or group of classes. Each letter prints on a separate page and includes the following letter sections:

- Enterprise Logo
- Enterprise Name
- Current Date
- Employee Information
- Greeting
- Introduction
- Class Information
- Closing

You can select to include or exclude any of these sections or change their content by using the Edit Class Correspondence action. You can select to include employees with a particular enrollment status.
**Class Rosters**

The Class Rosters report shows all employees on the class rosters of selected classes. The report is sorted by class start date and class ID number. Within each class group, the employees are sorted by enrollment status and last name. You can choose to include employees with a specific enrollment status or any status.

**Class Schedules**

The Class Schedules report lists classes that are in progress or scheduled to begin over a specified period of time. You can also include classes that are already completed or that have been canceled. The report is sorted by class start date.

**Mailing Labels**

This report prints mailing labels for all employees that are enrolled in a selected class or group of classes. You can select to include employees with a particular enrollment status. The report is formatted for label sheets with 30 labels per page (three columns of 10 labels each). If you print labels for more than one class, the labels for each separate class begin on a new sheet.

**Overbooked Classes**

The Overbooked Classes report lists classes that have more employees enrolled than the maximum capacity allows. The report is sorted by class start date.

**Participants' Training History**

This report summarizes the courses taken and the courses scheduled for each employee enrolled in a specific class. You can select more than one class, in which case a separate report is printed for each class. You can select to include employees with a particular enrollment status. If an employee’s status in a class is **Completed**, their grade (if any) appears in the **Grade** column; otherwise, their enrollment status appears.

**Employee Training Reports**

The Employee Training reports allow you to track completed and required courses, training programs and certifications for all employees, as well as training expenses and tuition reimbursements.

**Employee Certifications**

The Employee Certifications report shows all the certifications received or required by a selected group of employees. The report is sorted by employee last name. Within each employee group, the certifications are sorted by date required, with certifications that must be received the soonest listed first.
Employee Training Reports

Employee List
This report lists employees by last name. You can also select to include non-employees. Titles and organization levels are shown, if applicable.

Employee Required Courses
The Employee Required Courses report shows all courses that employees must complete over a specified period of time. Courses for each employee are sorted by priority and the date by which they must be completed, with courses that are most important and that must be completed soonest listed first.

Employee Training Profile
The Employee Training Profile report shows courses an employee has completed as well as courses that still need to be taken. It is a combination of the Training History by Employee and Employee Required Courses reports. If an employee’s status in a course is Completed, their grade (if any) appears in the Grade column; otherwise, their enrollment status appears.

Employee Training Programs
The Employee Training Programs report lists the training programs that employees have completed over a specified period. You can also include programs that are in progress. If training programs in progress are included, the report also shows courses completed and courses still remaining within each program.

Employees with a Certification
The Employees with a Certification report lists all employees who have received or require a certification. The report is sorted by certification code. Within each certification group, you can choose to order by employee name or by expiration date. You can include all certifications or only a specific certification.

Training Expenses by Employee
The Training Expenses by Employee report shows the expenses associated with courses completed by an employee during a specified period of time. You can also include courses that are scheduled but not yet completed. If an employee’s status in a course is Completed, their grade (if any) appears in the Grade column; otherwise, their enrollment status appears.

Training History by Employee
The Training History by Employee report lists courses completed by an employee over a specified period of time. You can also include courses that are scheduled but not yet completed. If an employee’s status in a course is Completed, their grade (if any) appears in the Grade column; otherwise, their enrollment status appears.
Training Schedules by Employee

The Training Schedules by Employee report lists courses that are in progress or scheduled to begin over a specified period of time. You can also include courses that have already been completed.

Tuition Reimbursements

This report lists the tuition reimbursements an employee has received or requested over a specified period of time. The report is sorted by employee last name. Within each employee group, courses completed most recently are listed first. You can select to include all courses, or only those of a particular type or with a particular status. If an employee’s status in a course is Completed, their grade (if any) appears in the Grade column; otherwise, their enrollment status appears.

Training Analysis Reports

Training Analysis reports allow you to track course fees and expenses, class attendance, class utilization, and class ratings.

Class Attendance Summary

The Class Attendance report summarizes the attendance totals for all classes offered over a period of time, grouped by course code. The report also includes the percentage of people that did not show up for class, the percentage that canceled and the percentage of available class space that was used.

Class Financial Summary

This report summarizes financial information for all classes offered over a period of time. Only classes with a status of completed are included in the report. The report compares budgeted costs with actual costs and total fees with actual costs. The Cost Per Student represents the additional cost per student (beyond fixed costs) and is calculated by subtracting the Average Fixed Costs from the Average Actual Costs and dividing by the Average Attendance. The Breakeven Fee is an estimate of the fee that should be charged to recover the total class costs and is calculated by dividing the Average Fixed Costs by the Average Attendance and adding the Cost Per Student.

Expenses by Course

The Expenses by Course report shows the expenses for all courses taken over a period of time, grouped by course code. You can choose to print just the total expenses for each course code or you can print the records for each course taken during the specified period. You can select to include employees with a particular enrollment status.

Expenses by Job Title

The Expenses by Job Title report shows the expenses for all courses taken over a period of time, grouped by job title. You can choose to print just the total expenses for each job title or you can print the records for
Training Analysis Reports

each course taken during the specified period. You can select to include employees with a particular enrollment status.

**Expenses by Org(organization) Level**

The Expenses by Org Level report shows the expenses for all courses taken over a period of time, grouped by organization level. You can choose to print just the total expenses for each organization level or you can print the records for each course taken during the specified period. You can select to include employees with a particular enrollment status.

**Training Exception**

Use the Training Exception report to determine which employees need training. The report lists all employees that need to take a specific course or specific courses and is sorted by course code. You can select to sort employees by name or by priority, in which case employees to whom the course is most important and who need to complete it the soonest are listed first. You can also select to include employees who are already scheduled to take the course.

**Training History by Course**

The Training History by Course report provides a list of all employees that have completed a specific course or are scheduled to complete a course. You can also select to include a number of courses, in which case the report is sorted by course code and all employees that have completed the course are grouped together. You can select to include employees with a particular enrollment status. If an employee’s status in a course is **Completed**, their grade (if any) appears in the **Grade** column; otherwise, their enrollment status appears. You can also select a specific date range.

**System Reports**

**Audit Trail Reports**

Sage Abra SQL HRMS provides an audit trail with which you can track the changes your data entry personnel make to the system databases. For each user who makes changes to Sage Abra SQL HRMS data, the audit trail records an employee number, a date and time, the type of change, and the new and old values of the affected data.

**Note:** The audit trail only tracks changes made to employees. It does not track changes to rules or setup activities.

**To Access Audit Trail Reports**

From the Navigation Pane, select **Reports > System > Audit Trail Reports**. The report options dialog box allows you to include specific files, fields, users or employees as well as to specify a date range. You can also build your own criteria to determine the content of the report.
There are three audit trail reports.

- **Audit Trail by Date** - This report provides a list of audit trail records sorted by the date on which the changes were made.
- **Audit Trail by File/Field** - This report provides a list of audit trail records sorted by the files and fields in which the changes were made.
- **Audit Trail by User** - This report provides a list of audit trail records sorted by the users who implemented the changes.

**Data Dictionary Reports**

To obtain the most recent version of the database structure, run the Data Dictionary reports.

**To Run Data Dictionary Reports**

1. From the Navigation Pane, select **Reports > System > Data Dictionary Reports**.
2. To print a list of database files, click the **Files List** radio button. To print a list of all the fields within each database file, click the **Fields List** radio button. To print a list of the **Index Keys**, click the **Index Keys List** radio button.
3. Select the products you want to appear on the report by checking the appropriate check boxes.
4. Click **Preview** to preview the report. When you are finished previewing, click the **Close** button to close the preview window.
5. Click **Print** to print the report.
6. Click the **Close** button to close the Data Dictionary Reports dialog box.

**Using Functions in Reports**

All field names beginning with an underscore are functions, and you might prefer to use them rather than the standard field names when creating custom reports.

You can use the special functions when creating reports by simply selecting a field name beginning with an underscore. For example, if you insert the field name _SEX, your report will display the field description of Male, Female or Unknown. for an employee’s gender. If you insert the field name P_Sex, your report will display the code M, F or U. Some of the functions (field names beginning with an underscore) do more than display a description rather than its code. The function _NAME1, for example, displays the employee’s name as: Last, First Middle.

**Note:** When you set up your organization levels, you provide a title for each level (Level1 = Division) and then define the Organization Code tables (codes and descriptions) for each level. If you want the description for an organization in a level (Accounting) to appear on your report rather than the code (ACCTG), select the related field name that begins with an underscore (_LEVEL1).
Custom Reports - Using Crystal Reports

Overview

Using Crystal Reports for Sage, you can create unique customized reports. Crystal Reports is a desktop query and reporting application that offers powerful data analysis capabilities. It enables you to produce a variety of presentation-quality reports with a minimum amount of effort. When you want to start creating your own custom reports, refer to the Crystal Reports Online Help for detailed instructions.

You can add new report groups containing any custom reports created in Crystal to the Reports Menu and order the items in these groups to suit your specific needs.

Sage Abra SQL HRMS is shipped with dozens of custom reports using Crystal Reports. The custom reports can be used as they are or use Crystal Reports for Sage to modify them to suit your employer’s needs. Custom reports are grouped into the following categories:

- Attendance
- HR
- Training

Abra Data Access

Abra Data Access provides ease of use and security for custom reporting using Crystal Reports for Sage with Sage Abra SQL HRMS.

You must be logged into Sage Abra SQL HRMS in order to work with any custom reports that specify Abra Data Access as the data source. When you select a custom report, Abra Data Access automatically verifies that you are logged into Sage Abra HRMS. If you are not, the Sage Abra HRMS logon page opens prompting you to log on.

After logged in, Abra Data Access checks a user’s security settings enabling you to enforce employer security, product group filters and ad hoc reporting security. If a user does not have access to a field:

- **Character fields** display Xs for the full size of field
- **Numeric fields** display 1 in the left most position and are zero filled for the remaining positions of the field
- **Date fields** display the date 01/01/1900

The first time you create your own custom report, you must specify Abra Data Access as the data source. You need to specify the data location only once. After specified, we recommend you add Abra Data Access to the Favorites list to enable you to quickly and easily select tables for custom reporting.
If you are using the custom reports shipped with Sage Abra HRMS, the data source automatically defaults to Abra Data Access.

**Specify Abra Data Access**

1. From the Sage Abra HRMS Quick Launch Toolbar, click the **Crystal** button to launch Crystal Reports. The Welcome to Crystal Reports dialog opens.
2. Select **As a Blank Report** and click **OK**. The Data Explorer dialog box opens.
3. Click **Options**. The Options dialog box opens.
4. In the List Tables and Fields by section, select **Both**.
5. Click **OK**. The Data Explorer dialog box opens.
6. Click the plus sign to expand **More Data Sources**.
7. Click the plus sign to expand **OLE DB**.
8. Click once to highlight **Make New Connection**.
9. Click **Add**. The Data Link Properties dialog box opens.
10. Click once to highlight **Abra Data Access (OLE DB Provider)**.
11. Click **OK**. The Data Explorer dialog box opens.
12. Under OLE DB, click once to highlight **Abra Data Access**.
13. Click **Add to Favorites**.
14. From the Data Explorer dialog box, click the plus sign to expand **Favorites**.
15. Click the plus sign to expand **Abra Data Access**.
16. Scroll through the list until you find the tables you want to include in the report and click once to highlight the tables.
17. Click **Add**. A check mark is added to the tables you select for the report.
18. Click **Close** when you’ve finished selecting the tables you need for the report.
19. The report opens in Design mode with the Field Explorer dialog box visible.

**Convert Database Driver to use Abra Data Access**

If you have created reports using Sage Abra SQL HRMS Live Data or Sage Abra SQL HRMS Sample Data, use the Convert Database Driver command to change the database driver to use Abra Data Access.

1. From the Sage Abra SQL HRMS Quick Launch Toolbar, click the **Crystal** button to launch Crystal Reports. The Welcome to Crystal Reports dialog opens.
2. Select **Open an Existing Report** and click **More Files**....
3. Click **OK**.
4. Navigate to the appropriate folder and open the .RPT file, for example, Employee List ZSI.rpt. The report opens in Design mode.
5. From the Crystal Reports Main Menu, select **Database > Convert Database Driver**. The Convert Database Driver dialog box opens.

6. Check the **Convert Database Driver on next Refresh** check box. The **To** drop-down list is enabled. From the **To** drop-down list, select pdsodbc.dll (OLEDB).

7. Click **OK**. The Data Link Properties dialog box opens.

8. Click once to highlight **Abra Data Access (OLE DB Provider)**.

9. Click **OK**. The Verify Database dialog box opens for each table included in the report.

10. Click **OK**. The report opens in Design mode.

11. From the Crystal Reports Main Menu, select **File > Save As** and save the report.

### Create a Custom Report

This topic is designed to walk you through the basic steps involved in creating a custom report using Crystal Reports. When you complete the tutorial and want to start creating more complex reports, refer to the Crystal Reports Online Help for detailed instructions.

**Note:** We recommend creating a sub-report for each multi-record database you add to the same report.

The report you will create will be an Employee Original Hire Date List report that retrieves the following information: employee first name, employee last name, and original hire date.

If you are creating a custom report for the first time, you must specify Abra Data Access as the data source.

1. From the Sage Abra SQL HRMS Quick Launch Toolbar, click the Crystal button to launch Crystal Reports. The Welcome to Crystal Reports dialog box opens.

2. Select **As a Blank Report** and click **OK**. The Data Explorer dialog box opens.

3. Click the plus sign to expand Favorites.

4. Click the plus sign to expand Abra Data Access.

5. Scroll through the list until you find the tables you want to include in the report and click once to highlight the tables. For this example HRPERSNL.

6. Click **Add**. A check mark is added to the tables you selected for the report.

7. Click **Close** when you have finished selecting the tables you need for the report.

8. The report opens in Design mode with the Field Explorer dialog box visible.

### To Add a Report Title

1. From the Crystal Reports Main Menu, select **Insert > Text Object**. The field appears as a floating object.

2. Drag the field to the location on the report, for this example to the upper right hand corner of the Page Header band line and click once to anchor it in place.
Create a Custom Report

3. Double-click in the text box and enter **Employee Original Hire Date List**.
4. Drag your cursor over the title to highlight the text.
5. From the main menu, select **Format > Font**. The Text Format dialog box opens.
6. From the **Size** drop-down list, select 14. Click **OK**.
7. If you need to expand the field to accommodate the larger text, move your cursor anywhere inside the text box and click once. The text box is highlighted and the crosshairs cursor displays.
8. Move the cursor to the right border of the text box until it changes to a left/right arrow.
9. Click and drag the cursor to resize the text box.

**Add Column Headings**

1. From the Crystal Reports Main Menu, select **Insert > Text Object**. The field appears as a floating object.
2. Drag the field to the desired location on the report, for this example to the lower left most position on the Page Header band line and click once to anchor it in place.
3. Double-click in the text box and enter **Employee Name**.
4. Drag your cursor over the title to highlight the text.
5. From the main menu select **Format > Font**. The Text Format dialog box opens.
6. From the Style drop-down list, select **Bold**. Click **OK**.
7. Repeat steps 1 through 6 to create a column heading for Original Hire Date, placing the column heading in center of the Page Header.

**Add the Data**

1. From the Main Menu, select **Insert > Field Object**. The Field Explorer dialog box opens.
2. Click the plus sign to expand **Database Fields and HRPERSNL**.
3. Left-click and drag **p_fname** to the desired location on the report, for this example to the left most position of the Details band line. This will insert the employee’s first name on the report.
4. From the main menu select **Format > Font**. The Text Format dialog box opens.
5. From the **Size** drop-down list, select 8. Click **OK**.
6. Repeat steps 1 through 5 to create columns for the employee’s last name using **p_lname** and date of birth using **p_orighire**.

**Format the Report**

1. Place your cursor over the separation line between the Page Header band line and the Details band line. The cursor changes to an up and down arrow.
2. Click once and drag the separation line down about 1/8 inch.
3. From the main menu, select **Insert > Line**. The cursor changes to a pencil.
4. Place the cursor on the Page Header band line under the Employee Name column heading.
5. Hold down the left mouse button and draw a line from the left side of the report to the right side of the report.
6. Right click on the line and select Format Line. The Format Editor dialog box opens.
7. Change the width to the widest option and click OK.
8. Repeat steps 1 through 7 using the Page Footer.
9. From the Crystal Reports Main Menu, select File > Save As and save the report.
10. From the Main Menu, select File > Print Preview to see the result.

Add a Table

If the report contains data from two or more database files, the database files must be linked. Database files are linked so records from one database match related records from another. When you link database files, a field is used that is common to both databases.

For example, you might want to add benefit plans descriptions and employee benefit premiums to the Employee report. When you add the Employee Benefit table (HBENE) and the Benefit Plan table (HBEPLAN) to the Employee Personnel table (HRPERSNL), the databases are linked so that each employee (from the Employee Personnel table) can be matched up with their benefit descriptions (from the Benefit Plan table) and each benefit description (from the Benefit Plan table) can be matched up with the employee benefit premium (from the Employee Benefit table).

1. From the Crystal Reports Main Menu, select Database > Add Database to Report. The Data Explorer dialog box opens.
2. From the Data Explorer dialog box, click the plus sign to expand Favorites.
3. Click the plus sign to expand Abra Data Access.
4. Scroll through the list until you find the tables you want to include in the report and click once on each table to highlight it. For this example HBENE and HBEPLAN.
5. Click Add. A check mark is added to the tables you are adding to the report.
6. Click Close when you’ve finished selecting the tables you need for the report. The Visual Linking Expert dialog box opens.
7. The dialog box shows all the tables currently in your report including any existing links.
8. Scroll through the primary database file, until you find the field you want to link. For this example p_empno in hrpersnl.
9. Left-click and drag the field from the primary database file to the corresponding field in the related database file. After the database files are linked, a link line is created from the field in the primary database to the corresponding field in the related database. For this example drag p_empno in HRPERSNL to b_empno in HBENE.
10. Repeat steps 8 and 9 dragging b_benecode in HBENE to code in HBEPLAN.
11. Click OK.
12. From the Main Menu, select **Insert > Field Object**. The Field Explorer dialog box opens.
13. Click the plus sign to expand **Database Fields and HBEPLAN**.
14. Left-click and drag **desc** to the desired location on the report. This will insert the benefit plan descriptions on the report.
15. Repeat steps 13 and 14 dragging **b_epremium** in HBENE to the desired location on the report. This will insert the employees’ benefit premiums on the report.

### Sorting, Grouping, and Totaling

Sorting, grouping, and totaling enable you to organize data into useful information on a report. This section describes the types of sorting, grouping, and totaling you can do using Crystal Reports.

#### Define a Sort Order

Sorting means arranging data in some kind of order to help you find and evaluate it. When you sort, Crystal asks you to define the field you want the sort to be based on (sort field) and the sort direction. Sort Direction refers to the order in which the values are displayed, once sorted.

- Ascending order means smallest to largest (1 to 9, A to Z, False to True).
- Descending order means largest to smallest (9 to 1, Z to A, True to False).

This example shows you how to sort the Employee report by the employee’s last name.

1. From the Crystal Reports Main Menu, select **Report > Sort Records**. The Record Sort Order dialog box opens.
2. From the **Report Fields** list, double-click **hpersnl.p_name**. The field moves to the **Sort Fields** list.
3. Select either ascending or descending as the **Sort Direction**.
4. Click **OK**.

#### Insert a Group

Grouped data is data that is divided into meaningful groups. This example shows you how to group the Employee Original Hire Date List report by the benefit plan description.

1. From the Crystal Reports Main Menu, select **Insert/Group**. The Insert Group dialog box opens.
2. From the first drop-down list, select **hbeplan.desc**.
3. Click **OK**. The report adds a Group Header #1 section and the field **Group #1 Name**.

#### Insert a Summary

Summaries enable you to calculate averages, counts, and other group values. This example shows you how to determine the number of employees in each group.

1. Click once to highlight the **p_name** field (not the column heading).
2. From the Crystal Reports Main Menu, select **Insert > Summary**. The Insert Summary dialog box opens.
3. From the first drop-down list, select **Count**.
4. Click **OK**. The numeric field is inserted in the Group Footer #1 area.
5. To the left of the **Summary** field, insert a text object called Employee Count.

**Insert a Subtotal**

Use the Subtotal command to insert a subtotal of the currently selected numeric field into your report. This example shows you how to add a subtotal to each groups benefit premium.

1. Click once to highlight the **p_epremium** field (not the column heading).
2. From the Crystal Reports Main Menu, select **Insert > Subtotal**. The Insert Subtotal dialog box opens.
3. Click **OK**. The numeric field is inserted in the Group Footer #1 area.
4. To the left of the **Subtotal** field, insert a text object called Subtotal.

**Insert a Grand Total**

Use the Grand Total command to print a report grand total of the currently selected numeric field at the end of the report.

This example shows you how to add a grand total to the report.

1. Click once to highlight the **p_epremium** field (not the column heading).
2. From the Crystal Reports Main Menu, select **Insert > Grand Total**. The Insert Grand Total dialog box opens.
3. From the first drop-down list, select **Sum**.
4. Click **OK**. The numeric field is inserted in the Report Footer area.
5. To the left of the **Grand Total** field, insert a text object called Grand Total.
6. From the main menu, select **File > Print Preview** and go to the last page of your report to see the result.

**Modify a Custom Report**

You can modify the appearance and type of information that appears on the custom reports provided with Sage Abra SQL HRMS. This example shows you how to add a field and label for the employee’s date of birth to the Employee List.rpt.

**Note:** You should never modify the original report. Make a copy before you modify it.

1. Use Windows Explorer to navigate to the appropriate product folder (HR, Attendance, or Training) located in **Sage Abra > Programs > Crystal**. Locate the report .RPT file you want to modify, for example, Employee List.rpt in the HR folder. Make a copy of it in the same product folder using a
different file name, for example Employee List ZSI.rpt. We recommend you copy the file using Explorer rather than using Save As in Crystal Reports.

2. From the Sage Abra SQL HRMS Quick Launch Toolbar, click the Crystal button to launch Crystal Reports. The Welcome to Crystal Reports dialog opens.

3. Select Open an Existing Report and More Files....

4. Click OK.

5. Navigate to the appropriate product folder located in Sage Abra > Programs > Crystal and open the copied RPT file, for example, Employee List ZSI.rpt. The report opens in Design mode.

6. The location for the data used in the custom reports defaults to Abra Data Access.

7. From the Crystal Reports Main Menu, select Insert > Text Object. The field appears as a floating object.

8. Drag the field to the desired location on the report, for this example between Name and Title and click once to anchor it in place.

9. Double-click in the text box and enter Date of Birth.

10. From the Main Menu, select Insert > Field Object. The Field Explorer dialog box opens.

11. Click the plus sign to expand Database Fields and HRPERSNL.

12. Left-click and drag p_birth to the desired location on the report, for this example between @Employee name and p_jobtitle.

13. From the main menu, select File > Print Preview to see the result.

14. From the main menu, select File > Save.

This example shows you how to remove the employee's salary.

1. Click the Design tab to enter into design mode.

2. On the Page Header band line, right-click on Salary and select Delete.

3. Right-click on the field name p_annual and select Delete.

4. From the main menu, select File > Print Preview to see the result.

5. From the main menu, select File > Save.

Custom Attendance Reports

Sage Abra SQL HRMS provides the following custom Attendance reports using Crystal Reports:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Absence Log</td>
<td>Lists the absence reason codes the employee has on record along with the date, weekday, number of hours and comments regarding each absence. This report includes parameters for the Beginning Hire Date and Ending Hire Date. From the menu, select File &gt; Print Preview. When the Enter Parameters Values dialog box opens, enter the values to use when running your report.</td>
</tr>
</tbody>
</table>
**Index**

### Name | Description
--- | ---
**Absenteeism by Reason** | Use this report to view absenteeism by absent reason in a graphical layout.

**Attendance Summary** | This report shows a summary of attendance information for each plan, including carryover hours, hours accrued, year-end eligibility, and hours taken.

**Attendance Totals by Plan** | This report provides attendance totals for each active employee for each plan. The report lists the employee name, employee number, the plan ID, carryover, hours accrued, taken, and available as of the current accrual date.

**Attendance YTD Detail** | This report shows detailed attendance plan information for each employee, including hours accrued, carryover, hours taken, hours available and as of date. It also lists the absence date, day, hours absent, and the absence reason.

**Attendance YTD Totals** | Use this report to view a summary of carryover hours, hours accrued, taken, and available as of the current accrual date.

### Custom HR Reports

#### Name | Description
--- | ---
**Age Listing** | This report enables you to view a list of employees sorted by age. The default fields include employee age and birth date, employee name, job title, and organization levels.

**Benefit Letter** | This report shows an employee’s annual costs and contributions for both savings and insurance benefits. The report, in letter format, is designed to be printed on company letterhead and given to the employee.

**Benefits Enrollment** | This report totals insurance benefits by employee. The report lists the employee monthly premium, employee monthly contribution, and the dependent monthly premium along with the effective date of the plan.

**Birthday List** | This report shows a list of birthdays by birth month. It lists the employee birth date, employee name, and employee address.

**Blank HR** | This report is designed to be used as a template for creating HR reports. It is linked to the employee master file and has the proper headers and footers already created.

**Blood Donor List** | This report lists each employee’s department and division, blood type, RH factor, and last donation date. It also provides the employee’s telephone extension.

**Census Report** | This report provides information your insurance company may require when calculating the cost of providing insurance. It provides detailed information for each employee including birth date, social security number, gender, employee type, occupation, annual salary, date of
### Custom HR Reports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Certificate of Coverage</td>
<td>The Certificate of Coverage provides proof of previous health insurance coverage for the employee. It includes the date the coverage began and ended as well as any covered dependents. This report includes parameters for the Date of Certificate, Group Health Plan, and Administrator Name. Before running the Certificate of Coverage report, you must specify the default plans to appear in the <strong>Group Health Plan</strong> parameter field.</td>
</tr>
<tr>
<td></td>
<td><strong>Steps to Specify Default Plans to Appear in the Group Health Plan Parameter Field</strong></td>
</tr>
<tr>
<td></td>
<td>1. From the Crystal Reports Main Menu, select <strong>Insert &gt; Field Object</strong>. The Field Explorer dialog box opens.</td>
</tr>
<tr>
<td></td>
<td>2. Click the plus sign to expand <strong>Parameter</strong> Fields.</td>
</tr>
<tr>
<td></td>
<td>3. Click once to highlight <strong>Group_Health_Plan</strong>.</td>
</tr>
<tr>
<td></td>
<td>4. From the Field Explorer dialog box toolbar, click the button. The Edit Parameter Field dialog box opens.</td>
</tr>
<tr>
<td></td>
<td>5. Click the <strong>Set default values</strong> button. The Set Default Values dialog box opens.</td>
</tr>
<tr>
<td></td>
<td>6. Select <strong>hbeplan</strong> from the <strong>Browse</strong> table drop-down list. Select code from the <strong>Browse</strong> field drop-down list.</td>
</tr>
<tr>
<td></td>
<td>7. Click Select or enter value to add list shows all the available group health plans. The <strong>Default Values</strong> list shows those plans you select.</td>
</tr>
<tr>
<td></td>
<td>8. From the <strong>Select</strong> or enter value to add list box, click once to highlight the plan you want to appear in the <strong>Group Health Plan</strong> parameter field.</td>
</tr>
<tr>
<td></td>
<td>9. Click the &gt; button to add the selected plan to the <strong>Default Values</strong> list box. If you want to remove a plan from the <strong>Default Values</strong> list, highlight it and click the &lt; button.</td>
</tr>
<tr>
<td></td>
<td>10. Use the <strong>Order</strong> arrow buttons to move a value up or down in the <strong>Default Values</strong> list.</td>
</tr>
<tr>
<td></td>
<td>11. When you finish, click <strong>OK</strong>. The Edit Parameter Field dialog box opens.</td>
</tr>
<tr>
<td></td>
<td>12. Click <strong>OK</strong>.</td>
</tr>
<tr>
<td></td>
<td>13. From the menu, select <strong>File &gt; Print Preview</strong>. When the Enter Parameters Values dialog box opens, enter the values to use when running your report.</td>
</tr>
<tr>
<td>Code Table Reports</td>
<td>Use this report to view a list of the defined codes in your code tables, for example, job codes, event codes, reason codes.</td>
</tr>
<tr>
<td>Dependent List</td>
<td>This report lists all employees and their dependents. It includes the dependent relationship, birth date, and social security number.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Dependent Update List</td>
<td>This report lists all employees and their dependents including the dependent relationship, birth date, and social security number. Use the update information section to document changes to dependent information.</td>
</tr>
<tr>
<td>Drug Screen Listing</td>
<td>The information on this report includes the employee’s name, date of the most recent drug test, its result, the number of years since the last test, and the date of the next test.</td>
</tr>
<tr>
<td>Emergency List</td>
<td>This report provides a list of employees and their emergency contacts.</td>
</tr>
<tr>
<td>Employee Address List</td>
<td>Select this report to view employee demographic information such as employee addresses and phone numbers.</td>
</tr>
<tr>
<td>Employee Benefits Summary</td>
<td>This summary lists employee insurance and savings benefits including the associated costs. The report displays all plans which do not have an expiration date or for which the expiration date is greater than the system date (not expired).</td>
</tr>
<tr>
<td>Employee Benefits With Dependents</td>
<td>This summary lists employee insurance and savings benefits including dependent benefit information. The report displays all plans which do not have an expiration date or for which the expiration date is greater than the system date (not expired).</td>
</tr>
<tr>
<td>Employee Count</td>
<td>This report is a count of all active and terminated employees.</td>
</tr>
<tr>
<td>Employee ID List</td>
<td>This report displays employee name and ID, job title, division, and department for each active employee.</td>
</tr>
<tr>
<td>Employee List</td>
<td>Select this report to view all active employees sorted in ascending order by employee number. The default fields include employee name and ID, job title, original hire date, and annual salary.</td>
</tr>
<tr>
<td>Employee List by Name</td>
<td>This report is an employee list sorted by employee name. It lists the employee name, employee number, job title, division, and department for each active employee.</td>
</tr>
<tr>
<td>Employee Monthly New Hire List</td>
<td>This report is a list employees grouped by division and department. The default fields include employee status, original hire date, and termination date.</td>
</tr>
<tr>
<td>Employee Phone List</td>
<td>This report provides a telephone directory for your employees. The default fields include employee name and ID, work telephone number, extension number, and organization levels.</td>
</tr>
<tr>
<td>Employee Profile</td>
<td>This report shows detailed information for each employee. It provides demographic, dependent, HR, and current job data.</td>
</tr>
<tr>
<td>Employees With No Benefits</td>
<td>Use this report to view a list of employees who do not have any insurance benefits.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Event Report</td>
<td>Select this report to view a list of employee events. Events are training, licenses, bonuses, professional memberships, company cars, or anything defined in the Events code table. It lists employee name, title, organization levels, event code, effective date, event description, next due date, and comments associated with each events.</td>
</tr>
<tr>
<td>Head Count By Division</td>
<td>Use this report to view all employees by division in a graphical layout.</td>
</tr>
<tr>
<td>Insurance Benefit Premium Summary</td>
<td>This summary lists employee insurance benefits including the associated costs. The report displays all insurance plans which do not have an expiration date or for which the expiration date is greater than the system date (not expired).</td>
</tr>
<tr>
<td>Insurance Benefit Premium Totals by Plan</td>
<td>This report displays the total premium for each plan including the number of employees enrolled in the plan. The report displays all insurance plans which do not have an expiration date or for which the expiration date is greater than the system date (not expired).</td>
</tr>
<tr>
<td>Job Code Table With Salary Grades</td>
<td>Use this report to view a list of the defined job codes including the associated salary grades.</td>
</tr>
<tr>
<td>Mail Labels</td>
<td>This report provides employees’ names and addresses printed in a two-column label format. You can adjust the information to print on the desired label stock.</td>
</tr>
<tr>
<td>Merit As Of</td>
<td>This report shows employees’ merits received as of a certain date. It lists the employee name, effective date, reason for the merit, and salary.</td>
</tr>
<tr>
<td></td>
<td>This report includes parameters for merit As Of Date. From the menu, select File &gt; Print Preview. When the Enter Parameters Values dialog box opens, enter the value to use when running your report.</td>
</tr>
<tr>
<td>New Hire Log</td>
<td>This report shows new hires for the date range entered. It shows the employee's effective date, employee name, title, employee status, pay rate, hours normally worked per pay period, and annual salary. The report provides totals for new hire salaries and an average of the salaries including a new hire count.</td>
</tr>
<tr>
<td></td>
<td>This report includes parameters for the Beginning Hire Date, and Ending Hire Date. From the menu, select File &gt; Print Preview. When the Enter Parameters Values dialog box opens, enter the values to use when running your report.</td>
</tr>
<tr>
<td>New Hire Reporting Form</td>
<td>The New Hire Reporting Form contains the standard information most states require for new hire reporting. You can modify this report to comply with your individual state’s requirements. Contact your state for specific details on submitting the New Hire Reporting Form. The default fields include</td>
</tr>
<tr>
<td></td>
<td>• Employer FEIN</td>
</tr>
<tr>
<td></td>
<td>• Employer Name</td>
</tr>
<tr>
<td></td>
<td>• Employer Address</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>OSHA 300 Illness Detail</td>
<td>This detail report shows employee illness cases as required by OSHA 300 report standards including the case number, date, and employee ID. It classifies totals by OSHA categories for Illness Types, Severity, and Number of Days. This report includes parameters for Start Date, End Date, and Case Types including Reportable, Nonreportable, or All Cases. From the menu, select <strong>File &gt; Print Preview</strong>. When the Enter Parameters Values dialog box opens, enter the values to use when running your report.</td>
</tr>
<tr>
<td>OSHA 300 Illness Summary</td>
<td>This summary shows a count of employee illness cases as required by OSHA 300 report standards. It classifies totals by OSHA categories for Illness Types, Severity, and Number of Days. This report includes parameters for Start Date, End Date, and Case Types including Reportable, Nonreportable, or All Cases. From the menu, select <strong>File &gt; Print Preview</strong>. When the Enter Parameters Values dialog box opens, enter the values you want to use when running your report.</td>
</tr>
<tr>
<td>OSHA 300 Injury Detail</td>
<td>This detail report shows employee injury cases as required by OSHA 300 report standards. It classifies totals by OSHA categories for Severity and Number of Days. This report includes parameters for Start Date, End Date, and Case Types including Reportable, Nonreportable, or All Cases. From the menu, select <strong>File &gt; Print Preview</strong>. When the Enter Parameters Values dialog box opens, enter the values to use when running your report.</td>
</tr>
<tr>
<td>OSHA 300 Injury Summary</td>
<td>This summary shows a count of employee injury cases as required by OSHA 300 report standards. It classifies totals by OSHA categories for Severity and Number of Days. This report includes parameters for Start Date, End Date, and Case Types including Reportable, Nonreportable, or All Cases. From the menu, select <strong>File &gt; Print Preview</strong>. When the Enter Parameters Values dialog box opens, enter the values to use when running your report.</td>
</tr>
</tbody>
</table>

This report includes parameters for the Beginning Hire Date and Ending Hire Date. From the menu, select **File > Print Preview**. When the Enter Parameters Values dialog box opens, enter the values to use when running your report.
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>the Enter Parameters Values dialog box opens, enter the values to use when running your report</td>
<td></td>
</tr>
<tr>
<td>OSHA 300 Log Detail</td>
<td>This report shows the number or work-related illnesses and injuries sustained by employees within a given time period. This report includes parameters for Start Date, End Date, and Case Types including Reportable, Nonreportable, or All Cases. From the menu, select File &gt; Print Preview. When the Enter Parameters Values dialog box opens, enter the values to use when running your report.</td>
</tr>
<tr>
<td>Physical Exams Due</td>
<td>This report provides the date of the employee’s last physical exam, the result of the exam, the date of the next physical, the number of years since the last physical, and the telephone extension.</td>
</tr>
<tr>
<td>Promotion List</td>
<td>Use this report to view an employee’s old job title, new job title, and the effective date of the new job. This report includes parameters for the Start Date and End Date. From the menu, select File &gt; Print Preview. When the Enter Parameters Values dialog box opens, enter the values to use when running your report.</td>
</tr>
<tr>
<td>Salary Analysis by Division, Department and Location</td>
<td>This report lists employees’ salaries by Division, Department, and Location. The report includes years of service, performance rating, and comparatio.</td>
</tr>
<tr>
<td>Salary Analysis by Job Code</td>
<td>This report lists employees’ salaries by Job Code. The report includes years of service, performance rating, and comparatio.</td>
</tr>
<tr>
<td>Salary Analysis by Name</td>
<td>This report lists employees’ salaries by employee name. The report includes years of service, performance rating, and comparatio.</td>
</tr>
<tr>
<td>Salary Grade</td>
<td>This report shows each employee’s salary and pay grade including the minimum, maximum and mid point of the salary grade.</td>
</tr>
<tr>
<td>Salary History</td>
<td>Use this report to produce an employee salary history. It lists pay rates, increase amounts, and percentages.</td>
</tr>
<tr>
<td>Salary Review Form</td>
<td>This detail report shows salary information including salary history and percent of increase. The report provides a form to submit job/salary changes.</td>
</tr>
<tr>
<td>Savings Benefit Coverage By Employee</td>
<td>This summary lists employee savings benefits including the associated contribution amounts. The report displays all savings plans which do not have an expiration date or for which the expiration date is greater than the system date (not expired).</td>
</tr>
<tr>
<td>Scheduler</td>
<td>This report shows scheduled tasks including the completion date and the person who scheduled the task.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Skills Listing</td>
<td>This report lists each employee’s skills including years of experience in each skill and a comment area that provides short details about each skill.</td>
</tr>
<tr>
<td>Spouse List</td>
<td>Use this report to view a list of employees and their spouses.</td>
</tr>
<tr>
<td>Terminated Employee Name List</td>
<td>This report lists terminated employees including employee name and ID, termination date, and termination reason.</td>
</tr>
<tr>
<td>Transfer Log</td>
<td>This report lists employees who have transferred within a specified date range. This report includes parameters for the Start Date and End Date. From the menu, select File &gt; Print Preview. When the Enter Parameters Values dialog box opens, enter the values to use when running your report.</td>
</tr>
<tr>
<td>Turnover Statistics</td>
<td>This report shows turnover statistics within a specified date range and calculates these statistics based on the Service Length selection. For each terminated employee, this report includes termination type, date, employee name and title, and service length. It also shows the turnover rate and summary statistics for the different termination types. This report includes parameters for Start Date, End Date and Service Length including Adjusted Seniority, Original Hire, or Last Hire. From the menu, select File &gt; Print Preview. When the Enter Parameters Values dialog box opens, enter the values to use when running your report.</td>
</tr>
<tr>
<td>Vets 100 Summary List</td>
<td>This report shows the number employees by job category for each Vets 100 category. The report includes newly hired veterans by category and total new hires for the 12 month period specified.</td>
</tr>
<tr>
<td>Vets 100 Detail List</td>
<td>This report shows employee names and IDs by job category for each Vets 100 category. The report includes newly hired veterans by category and total new hires for the 12 month period specified.</td>
</tr>
<tr>
<td>Vets 100A Summary List</td>
<td>This report shows the number employees by job category for each Vets 100A category. The report includes newly hired veterans by category and total new hires for the 12 month period specified. It displays a summarized list of the required report data in the Information on Employees section of the VETS-100A form.</td>
</tr>
<tr>
<td>Vets 100A Detail List</td>
<td>This report shows employee names and IDs by job category for each Vets 100A category. The report includes newly hired veterans by category and total new hires for the 12 month period specified. It displays a detailed list of the required report data in the Information on Employees section of the VETS-100A form.</td>
</tr>
</tbody>
</table>
## Custom Training Reports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Courses Completed By Employee</td>
<td>This report lists courses completed by an employee. The report includes a description of the course, instructor name, and length of the course in hours.</td>
</tr>
<tr>
<td>Expired Certifications</td>
<td>This report lists all employees with expired certifications. The information displayed includes employee name and ID, job title, date the certification was last received, and expiration date.</td>
</tr>
<tr>
<td>Job Training History</td>
<td>Use this report to view a list of courses completed by an employee over a specified period of time. The report shows employee name, job title, department, course name and description, course completion date, and length of the course in hours.</td>
</tr>
<tr>
<td>Training Budget By Department</td>
<td>This report shows the expenses associated with courses completed by an employee. Grouped by division and department, the report includes employee name and ID, job title, course code and description, the date by which the course must be completed, and the cost of the course.</td>
</tr>
<tr>
<td>Training Exceptions By Department</td>
<td>Use this report to determine which employees need training. The report lists all employees that need to take a specific course or specific courses and is grouped by division and department. The report includes employee name and ID, job title, the course description and priority, and the date the training course is required.</td>
</tr>
</tbody>
</table>
A

Abra Data Access, 63
Abra Secure Query
  group records, 18
  output results, 23
  select fields, 17
  set record filter, 19
  sort records, 18
  view data or run a query, 25
Absence Reason code table report, 29, 44
Accident Analysis by Injury report, 37, 38
Accident Analysis by Location report, 37, 38
Accident Analysis by Organization Level report, 37, 38
Accidents by Date report, 37, 38
Accidents by Employee report, 37, 38
Accidents Not Filed report, 37, 38
Age List report, 40
Anniversary List report, 35, 36
audit trail
  Audit Trail by Date report, 60
  Audit Trail by File/Field report, 60
  Audit Trail by User report, 60
  reports, 60
Audit Trail by Date report, 60
Audit Trail by File/Field report, 60

B

Bank reports, 47
Benefit Coverage by Employee report, 27
Benefit Enrollment by Plan report, 27
Benefit Insurance Plans code table report, 29, 44
Benefit Letter report, 27
Benefit Premium Totals by Plan report, 27
Benefit Savings Plans code table report, 29, 44
Birthday List report, 40
Blood Donor List report, 41

C

Census report, 27
Certificate of Coverage report, 27
Certification code table report, 55
Class Attendance Summary report, 59
Class Completion Letters report, 56
Class Enrollment Letters report, 56
Class Financial Summary report, 59
Class Ratings code table report, 55
Class Rosters report, 57
Class Schedules report, 57
COBRA Billing Statement report, 27
COBRA Mailing Labels report, 27
COBRA Notification Letter report, 27
Index

COBRA Recipient report, 27

code table reports

   Absence Reason, 31, 45
   Benefit Insurance Plans, 29, 44
   Benefit Type, 29, 44
   Certification, 55
   Class Ratings, 55
   Course Types, 55
   Courses, 55
   Dependent Relationship, 29, 44
   EEO Classification, 30, 44
   Employee Note Type, 30, 44
   Employee Type, 30, 44
   Enrollment Status, 55
   Event, 30, 44
   FMLA Event Reason, 30, 44
   Instructor Catalog, 55
   Instructor Ratings, 55
   Job, 55
   Job Requirements, 55
   Organization, 30, 45, 55
   OSHA Injury, 30, 45
   Priority, 55
   Rating, 30, 45
   Reason, 30, 44
   Salary Grades, 31, 45
   State, 55
   Training Locations, 55

Training Programs, 55

   User Defined, 55
   User-Defined, 31, 45, 55

   compa-ratio in reports, 31

   Convert Database to Abra Data Access, 64
   Course Types code table report, 55
   Courses code table report, 55
   Criteria Builder, 8
   Crystal Reports

   Abra Data Access, 63
   create a custom report, 65
   custom Attendance Reports, 70
   custom HR Reports, 71
   custom Training Reports, 78
   modify a custom report, 69
   sorting grouping and totaling, 68
   Custom Criteria Table, 7
   custom reports, 63

D

data dictionary

   data dictionary reports, 61

defining custom criteria for reports
   Criteria Builder, 8
   Criteria Table, 7

   Dependent Relationship code table report, 29, 44
   Drug Tests Due report, 41
E

EEO Classification code table report, 29, 44
EEO Job Group Age Analysis report, 33
EEO Job Group code table report, 29, 44
EEO Job Group Headcount report, 33
EEO New Hire Headcount Detail report, 33
EEO New Hire Headcount Summary report, 33
EEO Termination Detail report, 33
EEO Termination Summary report, 33
EEO-1 Headcount Summary report, 33
EEO-4 Headcount Detail report, 33
EEO-4 Headcount Summary report, 33
EEO-4 Job Function code table report, 29, 44
emailing
reports, 9
Emergency Contacts report, 41
Employee Attachments report, 40
Employee Benefit Changes report, 27
Employee Certifications report, 57
Employee Count report, 40
Employee List report, 40, 57
Employee Note Type code table report, 29, 44
Employee Notes report, 40
Employee Required Courses report, 58
Employee Training Profile report, 58
Employee Training Programs report, 58
Employees Currently on FMLA report, 37
Employees with a Certification report, 58
Enrollment Status code table report, 55
Event code table report, 29, 44
Event report, 35, 36
Expenses by Course report, 59
Expenses by Job Title report, 59
Expenses by Organization Level report, 59
exporting
reports, 9

F

FMLA Due to Return report, 37
FMLA Event Reason code table report, 29, 44

G

Government reports, 50

H

Health Profile report, 41
Home Mailing Labels report, 40

I

I-9 Citizenship Verification report, 33
Instructor Catalog code table report, 55
Instructor Ratings code table report, 55
Insurance Coverage Detail report, 27

J

Job code table report, 55
Job Requirements code table report, 55
M
Mailing Labels report, 56
Medical Recertification report, 37
modify custom report templates, 69

N
New Hire Log report, 35, 36

O
Organization code table report, 29, 44, 55
Organizational report, 35, 36
OSHA
reports, 37, 38
OSHA 300 Log report, 37, 38
OSHA 301 Incident report, 37, 38
OSHA Body Part code table report, 29, 44
OSHA Injury code table report, 29, 44
Overbooked Classes report, 57

P
Page Preview toolbar, 10
Participant Training History report, 56
Payroll reports
   Bank reports, 47
   Employee, 49
   Government reports, 50
   Periodic Processing reports, 51
   Setup reports, 51
   Tax reports, 52
   Transaction reports, 53
   Periodic Processing reports, 51
   previewing reports, 9
   printing reports, 9
   Priority code table report, 55
   query
      group records, 18
      output results, 23
      select fields, 17
      set record filter, 19
      sort records, 18

R
Ranked Salary List report, 31
Rating code table report, 29, 44
Reason code table report, 29, 44
report options
   classes and courses to include, 3
   custom criteria, 7
   employees to include, 3
   employers to include, 3
   organization levels to include, 3
   report list, 4
   selecting classes and courses, 3
   selecting employees by status, 3
   selecting organization levels, 3
   selecting the employers, 3
Index

specific criteria, 3
specific status selections, 3
standard criteria, 4
reporting, 63
custom, 63
Review Forms for Reviews Due report, 31

S
Salary Analysis by Employee Name report, 31
Salary Analysis by Organization report, 31
Salary Analysis by Salary Grade report, 31
Salary As Of report, 31
Salary Grade Range Exceptions report, 31
Salary History report, 31
Salary Increase Analysis by Job Code report, 31
Salary Increase Analysis by Organization report, 31
Salary Increase Analysis by Reason report, 31
selecting report options
classes to include, 3
courses to include, 3
employees to include, 3
employers to include, 3
organization levels to include, 3
report list, 4
specific criteria, 7
standard criteria, 4
sending reports, 9
Service List report, 35, 36
set database location, 63
Shift Differential code table report, 29, 44
Skill and Education List report, 41
Skill code table report, 29, 44
Skill Retrieval report, 41
Sorting Grouping and Totaling, 68
Source-of-Hire Activity report, 35, 36
State code table report, 29, 44, 55
Statistics by Job Code report, 31

T
Tax reports, 52
Telephone Directory report, 35, 36
Terminated Employee Log report, 31
toolbars
Page Preview toolbar, 10
Training Exception report, 60
Training Expenses by Employee report, 58
Training History by Course report, 60
Training History by Employee report, 58
Training Locations code table report, 55
Training Programs code table report, 55
Training Schedules by Employee report, 59
Transaction reports, 53
Tuition Reimbursements report, 57
Turnover Performance vs Longevity report, 31
Turnover Statistics report, 31

U
Union report, 35, 36
Index

User Defined code table report, 29, 44
User-Defined code table report, 55

V
Veterans Employment report, 33

W
Work Phone List report, 40
Workers’ Compensation Open Claims report, 37, 38